{"answers":{"affected":"2 open source packages ship an affected version, including com.graphhopper:graphhopper-nav. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-29506 in the wild and no public exploit code.","fix":"Upgrade com.graphhopper:graphhopper-nav to 2.4 or later.","what":"CVE-2021-29506 is a medium-severity denial of service vulnerability in graphhopper, published on 13 May 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-29506 and fix it if it is affected.\n\nWhat it is: CVE-2021-29506 is a medium-severity denial of service vulnerability in graphhopper, published on 13 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-29506 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.graphhopper:graphhopper-nav (Maven): affected all versions; fixed in 2.4\n- com.graphhopper:graphhopper-nav (Maven): affected all versions; fixed in 2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-29506/ (Markdown: https://insights.sbomify.com/CVE-2021-29506/index.md)","id":"CVE-2021-29506","markdown":"https://insights.sbomify.com/CVE-2021-29506/index.md","name":"CVE-2021-29506","record":{"aliases":["GHSA-hf44-3mx6-vhhw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java routing engine","requires_auth":"low_privilege","summary":"Attackers can cause a Denial of Service in GraphHopper via regex injection in the Navigate endpoint, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"graphhopper","vendor":"graphhopper"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"GraphHopper is an open-source Java routing engine. In GrassHopper from version 2.0 and before version 2.4, there is a regular expression injection vulnerability that may lead to Denial of Service. This has been patched in 2.4 and 3.0 See this pull request for the fix: https://github.com/graphhopper/graphhopper/pull/2304","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Navigate endpoint is vulnerable to regex injection that may lead to Denial of Service.","id":"CVE-2021-29506","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"dlt-daemon could crash if there is special character in dlt.conf","id":"CVE-2021-29507"},"packages":[{"ecosystem":"Maven","fixed":["2.4"],"introduced":["0"],"last_affected":[],"package":"com.graphhopper:graphhopper-nav","purl":null,"source":"GHSA-hf44-3mx6-vhhw"},{"ecosystem":"Maven","fixed":["2.4"],"introduced":["0"],"last_affected":[],"package":"com.graphhopper:graphhopper-nav","purl":"pkg:maven/com.graphhopper/graphhopper-nav","source":"GHSA-hf44-3mx6-vhhw"}],"prev":{"headline":"XStream is vulnerable to a Remote Command Execution attack","id":"CVE-2021-29505"},"products":["graphhopper"],"published":"2021-05-13","related":[{"cvss_score":5.4,"headline":"Prototype Pollution","id":"CVE-2021-23408","kev_date_added":null,"published":"2021-07-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["graphhopper"]},"summary":"Attackers can cause a Denial of Service in GraphHopper via regex injection in the Navigate endpoint, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2021-29506/"}