# CVE-2021-29506: Navigate endpoint is vulnerable to regex injection that may lead to Denial of Service.

> Attackers can cause a Denial of Service in GraphHopper via regex injection in the Navigate endpoint, requiring an upgrade to patched versions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hf44-3mx6-vhhw

## What is CVE-2021-29506?

CVE-2021-29506 is a medium-severity denial of service vulnerability in graphhopper, published on 13 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GraphHopper is an open-source Java routing engine. In GrassHopper from version 2.0 and before version 2.4, there is a regular expression injection vulnerability that may lead to Denial of Service. This has been patched in 2.4 and 3.0 See this pull request for the fix: https://github.com/graphhopper/graphhopper/pull/2304

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-29506?

2 open source packages ship an affected version, including com.graphhopper:graphhopper-nav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.graphhopper:graphhopper-nav` | Maven | All versions | 2.4 |
| `com.graphhopper:graphhopper-nav` | Maven | All versions | 2.4 |

Products: Graphhopper Graphhopper.

## How do I fix CVE-2021-29506?

Upgrade com.graphhopper:graphhopper-nav to 2.4 or later.

## Is CVE-2021-29506 being exploited?

There is no known exploitation of CVE-2021-29506 in the wild and no public exploit code.

## Other vulnerabilities in graphhopper

- [CVE-2021-23408](https://insights.sbomify.com/CVE-2021-23408/): Prototype Pollution (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29506 and fix it if it is affected.

What it is: CVE-2021-29506 is a medium-severity denial of service vulnerability in graphhopper, published on 13 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29506 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.graphhopper:graphhopper-nav (Maven): affected all versions; fixed in 2.4
- com.graphhopper:graphhopper-nav (Maven): affected all versions; fixed in 2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29506/ (Markdown: https://insights.sbomify.com/CVE-2021-29506/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29506
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29506
- OSV: https://osv.dev/vulnerability/CVE-2021-29506

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29506/
Summaries are generated and may contain mistakes; the official description above is the record.
