CVE-2021-29518 Session operations in eager mode lead to null pointer dereferences

Low 2.5 Published Updated

Attackers can cause a denial of service via null pointer dereference in TensorFlow eager mode by calling invalid session operations.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2021-29518?

CVE-2021-29518 is a low-severity vulnerability in Google Tensorflow, published on 14 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

TensorFlow is an end-to-end open source platform for machine learning. In eager mode (default in TF 2.0 and later), session operations are invalid. However, users could still call the raw ops associated with them and trigger a null pointer dereference. The implementation(https://github.com/tensorflow/tensorflow/blob/eebb96c2830d48597d055d247c0e9aebaea94cd5/tensorflow/core/kernels/session_ops.cc#L104) dereferences the session state pointer without checking if it is valid. Thus, in eager mode, `ctx->session_state()` is nullptr and the call of the member function is undefined behavior. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range.

Weakness: CWE-476

Which versions are affected by CVE-2021-29518?

28 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.

PackageAffectedFixed in
tensorflow BitnamiAll versions2.1.4, 2.2.3, 2.3.3, 2.4.2
tensorflow PyPIAll versions2.1.4, 2.2.3, 2.3.3, 2.4.2
tensorflow PyPIAll versions2.1.4
tensorflow PyPIAll versions2.1.4
tensorflow PyPIFrom 2.2.02.2.3
tensorflow PyPIFrom 2.2.02.2.3
22 more packages
tensorflow PyPIFrom 2.3.02.3.3
tensorflow PyPIFrom 2.3.02.3.3
tensorflow PyPIFrom 2.4.02.4.2
tensorflow PyPIFrom 2.4.02.4.2
tensorflow-cpu PyPIAll versions2.1.4, 2.2.3, 2.3.3, 2.4.2
tensorflow-cpu PyPIAll versions2.1.4
tensorflow-cpu PyPIAll versions2.1.4
tensorflow-cpu PyPIFrom 2.2.02.2.3
tensorflow-cpu PyPIFrom 2.2.02.2.3
tensorflow-cpu PyPIFrom 2.3.02.3.3
tensorflow-cpu PyPIFrom 2.3.02.3.3
tensorflow-cpu PyPIFrom 2.4.02.4.2
tensorflow-cpu PyPIFrom 2.4.02.4.2
tensorflow-gpu PyPIAll versions2.1.4, 2.2.3, 2.3.3, 2.4.2
tensorflow-gpu PyPIAll versions2.1.4
tensorflow-gpu PyPIAll versions2.1.4
tensorflow-gpu PyPIFrom 2.2.02.2.3
tensorflow-gpu PyPIFrom 2.2.02.2.3
tensorflow-gpu PyPIFrom 2.3.02.3.3
tensorflow-gpu PyPIFrom 2.3.02.3.3
tensorflow-gpu PyPIFrom 2.4.02.4.2
tensorflow-gpu PyPIFrom 2.4.02.4.2

Products include Google Tensorflow.

How do I fix CVE-2021-29518?

Upgrade tensorflow to a fixed version for your release line: 2.1.4, 2.2.3, 2.3.3 or 2.4.2.

Is CVE-2021-29518 being exploited?

There is no known exploitation of CVE-2021-29518 in the wild and no public exploit code.

All Google Tensorflow vulnerabilities

Sources

Also known as BIT-tensorflow-2021-29518, GHSA-62gx-355r-9fhg, PYSEC-2021-155, PYSEC-2021-446, PYSEC-2021-644.

Is CVE-2021-29518 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free