# CVE-2021-29624: Lack of protection against cookie tossing attacks in fastify-csrf

> Attackers can bypass CSRF protection in multi-subdomain deployments if developers fail to supply user-specific data during token generation.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-rc4q-9m69-gqp8

## What is CVE-2021-29624?

CVE-2021-29624 is a medium-severity vulnerability in fastify-csrf, published on 19 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

fastify-csrf is an open-source plugin helps developers protect their Fastify server against CSRF attacks. Versions of fastify-csrf prior to 3.1.0 have a "double submit" mechanism using cookies with an application deployed across multiple subdomains, e.g. "heroku"-style platform as a service. Version 3.1.0 of the fastify-csrf fixes it. the vulnerability. The user of the module would need to supply a `userInfo` when generating the CSRF token to fully implement the protection on their end. This is needed only for applications hosted on different subdomains.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-565 (Reliance on Cookies without Validation and Integrity Checking)

## Which versions are affected by CVE-2021-29624?

2 open source packages ship an affected version, including fastify-csrf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastify-csrf` | npm | All versions | 3.1.0 |
| `fastify-csrf` | npm | All versions | 3.1.0 |

Products: Fastify Fastify-Csrf.

## How do I fix CVE-2021-29624?

Upgrade fastify-csrf to 3.1.0 or later.

## Is CVE-2021-29624 being exploited?

There is no known exploitation of CVE-2021-29624 in the wild and no public exploit code.

## Other vulnerabilities in fastify-csrf

- [CVE-2020-28482](https://insights.sbomify.com/CVE-2020-28482/): Cross-site Request Forgery (CSRF) (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29624 and fix it if it is affected.

What it is: CVE-2021-29624 is a medium-severity vulnerability in fastify-csrf, published on 19 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-29624 in the wild and no public exploit code.

Affected packages and fixed versions:
- fastify-csrf (npm): affected all versions; fixed in 3.1.0
- fastify-csrf (npm): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29624/ (Markdown: https://insights.sbomify.com/CVE-2021-29624/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29624
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29624
- OSV: https://osv.dev/vulnerability/CVE-2021-29624

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29624/
Summaries are generated and may contain mistakes; the official description above is the record.
