CVE-2021-29625 XSS in doc_link

High 7.5 Published Updated

Cross-site scripting in Adminer allows attackers to execute scripts in victim browsers when using PDO extensions without strict CSP.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-29625?

CVE-2021-29625 is a high-severity cross-site scripting vulnerability in vrana adminer, published on 19 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Adminer is open-source database management software. A cross-site scripting vulnerability in Adminer versions 4.6.1 to 4.8.0 affects users of MySQL, MariaDB, PgSQL and SQLite. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a `pdo_` extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected. The vulnerability is patched in version 4.8.1. As workarounds, one can use a browser supporting strict CSP or enable the native PHP extensions (e.g. `mysqli`) or disable displaying PHP errors (`display_errors`).

Weakness: CWE-79

Which versions are affected by CVE-2021-29625?

2 open source packages ship an affected version, including vrana/adminer. It affects 1 product.

PackageAffectedFixed in
vrana/adminer PackagistFrom 4.7.84.8.1
vrana/adminer PackagistFrom 4.7.84.8.1

Products include Adminer Adminer.

How do I fix CVE-2021-29625?

Upgrade vrana/adminer to 4.8.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-29625 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-29625 exists.

Public exploit code: 1 Nuclei template.

Sources

Also known as DEBIAN-CVE-2021-29625, GHSA-2v82-5746-vwqc, UBUNTU-CVE-2021-29625.

Is CVE-2021-29625 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free