{"answers":{"affected":"2 open source packages ship an affected version, including vrana/adminer. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-29625 exists.","fix":"Upgrade vrana/adminer to 4.8.1 or later.","what":"CVE-2021-29625 is a high-severity cross-site scripting vulnerability in vrana adminer, published on 19 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-29625 and fix it if it is affected.\n\nWhat it is: CVE-2021-29625 is a high-severity cross-site scripting vulnerability in vrana adminer, published on 19 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-29625 exists.\n\nAffected packages and fixed versions:\n- vrana/adminer (Packagist): affected from 4.7.8; fixed in 4.8.1\n- vrana/adminer (Packagist): affected from 4.7.8; fixed in 4.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-29625/ (Markdown: https://insights.sbomify.com/CVE-2021-29625/index.md)","id":"CVE-2021-29625","markdown":"https://insights.sbomify.com/CVE-2021-29625/index.md","name":"CVE-2021-29625","record":{"aliases":["DEBIAN-CVE-2021-29625","GHSA-2v82-5746-vwqc","UBUNTU-CVE-2021-29625"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Database management tool","requires_auth":"none","summary":"Cross-site scripting in Adminer allows attackers to execute scripts in victim browsers when using PDO extensions without strict CSP.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"adminer","vendor":"adminer"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Adminer is open-source database management software. A cross-site scripting vulnerability in Adminer versions 4.6.1 to 4.8.0 affects users of MySQL, MariaDB, PgSQL and SQLite. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a `pdo_` extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected. The vulnerability is patched in version 4.8.1. As workarounds, one can use a browser supporting strict CSP or enable the native PHP extensions (e.g. `mysqli`) or disable displaying PHP errors (`display_errors`).","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2021/CVE-2021-29625.yaml","stars":null,"title":"Adminer \u003c=4.8.0 - Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"XSS in doc_link","id":"CVE-2021-29625","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Use after free in FreeBSD","id":"CVE-2021-29626"},"packages":[{"ecosystem":"Packagist","fixed":["4.8.1"],"introduced":["4.7.8"],"last_affected":[],"package":"vrana/adminer","purl":null,"source":"GHSA-2v82-5746-vwqc"},{"ecosystem":"Packagist","fixed":["4.8.1"],"introduced":["4.7.8"],"last_affected":[],"package":"vrana/adminer","purl":"pkg:composer/vrana/adminer","source":"GHSA-2v82-5746-vwqc"}],"prev":{"headline":"Lack of protection against cookie tossing attacks in fastify-csrf","id":"CVE-2021-29624"},"products":["adminer"],"published":"2021-05-19","related":[{"cvss_score":7.2,"headline":"Adminer Server-Side Request Forgery","id":"CVE-2021-21311","kev_date_added":"2025-09-29","published":"2021-02-11"},{"cvss_score":9.8,"headline":"vrana/adminer vulnerable to SSRF by connecting to privileged ports","id":"CVE-2018-7667","kev_date_added":null,"published":"2018-03-05"},{"cvss_score":8.6,"headline":"Adminer PHP Object Injection issue leads to Denial of Service","id":"CVE-2025-43960","kev_date_added":null,"published":"2025-08-25"},{"cvss_score":7.5,"headline":"Adminer has an Unauthenticated Persistent DoS via Array Injection in ?script=version Endpoint","id":"CVE-2026-25892","kev_date_added":null,"published":"2026-02-09"},{"cvss_score":7.5,"headline":"Files or Directories Accessible to External Parties in Adminer","id":"CVE-2021-43008","kev_date_added":null,"published":"2022-04-05"},{"cvss_score":6.1,"headline":"vrana/adminer via XSS in the history parameter in SQL command","id":"CVE-2020-35572","kev_date_added":null,"published":"2021-02-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["vrana"]},"summary":"Cross-site scripting in Adminer allows attackers to execute scripts in victim browsers when using PDO extensions without strict CSP.","url":"https://insights.sbomify.com/CVE-2021-29625/"}