# CVE-2021-29625: XSS in doc_link

> Cross-site scripting in Adminer allows attackers to execute scripts in victim browsers when using PDO extensions without strict CSP.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-29625, GHSA-2v82-5746-vwqc, UBUNTU-CVE-2021-29625

## What is CVE-2021-29625?

CVE-2021-29625 is a high-severity cross-site scripting vulnerability in vrana adminer, published on 19 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Adminer is open-source database management software. A cross-site scripting vulnerability in Adminer versions 4.6.1 to 4.8.0 affects users of MySQL, MariaDB, PgSQL and SQLite. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a `pdo_` extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected. The vulnerability is patched in version 4.8.1. As workarounds, one can use a browser supporting strict CSP or enable the native PHP extensions (e.g. `mysqli`) or disable displaying PHP errors (`display_errors`).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-29625?

2 open source packages ship an affected version, including vrana/adminer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vrana/adminer` | Packagist | From 4.7.8 | 4.8.1 |
| `vrana/adminer` | Packagist | From 4.7.8 | 4.8.1 |

Products: Adminer Adminer.

## How do I fix CVE-2021-29625?

Upgrade vrana/adminer to 4.8.1 or later.

## Is CVE-2021-29625 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-29625 exists.

Public exploit code:

- Adminer <=4.8.0 - Cross-Site Scripting (nuclei): http/cves/2021/CVE-2021-29625.yaml

## Other vulnerabilities in vrana adminer

- [CVE-2021-21311](https://insights.sbomify.com/CVE-2021-21311/): Adminer Server-Side Request Forgery (high 7.2, exploited in the wild)
- [CVE-2018-7667](https://insights.sbomify.com/CVE-2018-7667/): vrana/adminer vulnerable to SSRF by connecting to privileged ports (critical 9.8)
- [CVE-2025-43960](https://insights.sbomify.com/CVE-2025-43960/): Adminer PHP Object Injection issue leads to Denial of Service (high 8.6)
- [CVE-2026-25892](https://insights.sbomify.com/CVE-2026-25892/): Adminer has an Unauthenticated Persistent DoS via Array Injection in ?script=version Endpoint (high 7.5)
- [CVE-2021-43008](https://insights.sbomify.com/CVE-2021-43008/): Files or Directories Accessible to External Parties in Adminer (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29625 and fix it if it is affected.

What it is: CVE-2021-29625 is a high-severity cross-site scripting vulnerability in vrana adminer, published on 19 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-29625 exists.

Affected packages and fixed versions:
- vrana/adminer (Packagist): affected from 4.7.8; fixed in 4.8.1
- vrana/adminer (Packagist): affected from 4.7.8; fixed in 4.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29625/ (Markdown: https://insights.sbomify.com/CVE-2021-29625/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29625
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29625
- OSV: https://osv.dev/vulnerability/CVE-2021-29625

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29625/
Summaries are generated and may contain mistakes; the official description above is the record.
