# CVE-2021-29653: Security feature bypass in n/a

> Attackers can use revoked certificates because Vault fails to exclude them from the CRL, bypassing certificate revocation checks.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-vault-2021-29653, GHSA-gw8r-qv92-434x

## What is CVE-2021-29653?

CVE-2021-29653 is a high-severity vulnerability in Hashicorp Vault, published on 22 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HashiCorp Vault and Vault Enterprise 1.5.1 and newer, under certain circumstances, may exclude revoked but unexpired certificates from the CRL. Fixed in 1.5.8, 1.6.4, and 1.7.1.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2021-29653?

1 open source package ship an affected version, including vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vault` | Bitnami | From 1.5.1 | 1.5.8, 1.6.4, 1.7.1 |

Products: Hashicorp Vault.

## How do I fix CVE-2021-29653?

Upgrade vault to a fixed version for your release line: 1.5.8, 1.6.4 or 1.7.1.

## Is CVE-2021-29653 being exploited?

There is no known exploitation of CVE-2021-29653 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29653 and fix it if it is affected.

What it is: CVE-2021-29653 is a high-severity vulnerability in Hashicorp Vault, published on 22 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29653 in the wild and no public exploit code.

Affected packages and fixed versions:
- vault (Bitnami): affected from 1.5.1; fixed in 1.5.8, 1.6.4, 1.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29653/ (Markdown: https://insights.sbomify.com/CVE-2021-29653/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29653
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29653
- OSV: https://osv.dev/vulnerability/CVE-2021-29653

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29653/
Summaries are generated and may contain mistakes; the official description above is the record.
