# CVE-2021-29937: Free of uninitialized memory in telemetry

> A vulnerability in the Rust telemetry crate allows attackers to cause a crash or undefined behavior by triggering a panic during a clone operation on uninitialized memory.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hpcx-3pw8-g3j2

## What is CVE-2021-29937?

CVE-2021-29937 is a critical memory corruption vulnerability in n/a, published on 1 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the telemetry crate through 2021-02-17 for Rust. There is a drop of uninitialized memory if a value.clone() call panics within misc::vec_with_size().

Weakness: CWE-908 (Use of Uninitialized Resource)

## Which versions are affected by CVE-2021-29937?

2 open source packages ship an affected version, including telemetry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `telemetry` | crates.io | All versions | 0.1.3 |
| `telemetry` | crates.io | All versions | 0.1.3 |

Products: Telemetry Project Telemetry.

## How do I fix CVE-2021-29937?

Upgrade telemetry to 0.1.3 or later.

## Is CVE-2021-29937 being exploited?

There is no known exploitation of CVE-2021-29937 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29937 and fix it if it is affected.

What it is: CVE-2021-29937 is a critical memory corruption vulnerability in n/a, published on 1 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29937 in the wild and no public exploit code.

Affected packages and fixed versions:
- telemetry (crates.io): affected all versions; fixed in 0.1.3
- telemetry (crates.io): affected all versions; fixed in 0.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29937/ (Markdown: https://insights.sbomify.com/CVE-2021-29937/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29937
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29937
- OSV: https://osv.dev/vulnerability/CVE-2021-29937

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29937/
Summaries are generated and may contain mistakes; the official description above is the record.
