# CVE-2021-29939: Out of bounds write in stackvector

> An out-of-bounds write in the Rust stackvector crate allows attackers to cause memory corruption, potentially leading to code execution or crashes.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2021
- **Updated:** 19 Nov 2024
- **Also known as:** DEBIAN-CVE-2021-29939, GHSA-9frf-r7c7-j2vg, RUSTSEC-2021-0048, UBUNTU-CVE-2021-29939

## What is CVE-2021-29939?

CVE-2021-29939 is a high-severity memory corruption vulnerability in n/a, published on 1 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the stackvector crate through 2021-02-19 for Rust. There is an out-of-bounds write in StackVec::extend if size_hint provides certain anomalous data.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2021-29939?

3 open source packages ship an affected version, including stackvector. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stackvector` | crates.io | All versions | 1.0.9 |
| `stackvector` | crates.io | All versions | 1.0.9 |
| `stackvector` | crates.io | From 0.0.0-0 | 1.0.9 |

Products: Stackvector Project Stackvector.

## How do I fix CVE-2021-29939?

Upgrade stackvector to 1.0.9 or later.

## Is CVE-2021-29939 being exploited?

There is no known exploitation of CVE-2021-29939 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29939 and fix it if it is affected.

What it is: CVE-2021-29939 is a high-severity memory corruption vulnerability in n/a, published on 1 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29939 in the wild and no public exploit code.

Affected packages and fixed versions:
- stackvector (crates.io): affected all versions; fixed in 1.0.9
- stackvector (crates.io): affected all versions; fixed in 1.0.9
- stackvector (crates.io): affected from 0.0.0-0; fixed in 1.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29939/ (Markdown: https://insights.sbomify.com/CVE-2021-29939/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29939
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29939
- OSV: https://osv.dev/vulnerability/CVE-2021-29939

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29939/
Summaries are generated and may contain mistakes; the official description above is the record.
