# CVE-2021-29941: Out of bounds write in reorder

> An out-of-bounds write in the Rust reorder crate allows attackers to cause memory corruption, potentially leading to code execution or crashes.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-3h87-v52r-p9rg

## What is CVE-2021-29941?

CVE-2021-29941 is a high-severity memory corruption vulnerability in n/a, published on 1 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the reorder crate through 2021-02-24 for Rust. swap_index has an out-of-bounds write if an iterator returns a len() that is too small.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2021-29941?

2 open source packages ship an affected version, including reorder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `reorder` | crates.io | All versions | 1.1.0 |
| `reorder` | crates.io | All versions | 1.1.0 |

Products: Reorder Project Reorder.

## How do I fix CVE-2021-29941?

Upgrade reorder to 1.1.0 or later.

## Is CVE-2021-29941 being exploited?

There is no known exploitation of CVE-2021-29941 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-29942](https://insights.sbomify.com/CVE-2021-29942/): Out of bounds write in reorder (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29941 and fix it if it is affected.

What it is: CVE-2021-29941 is a high-severity memory corruption vulnerability in n/a, published on 1 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29941 in the wild and no public exploit code.

Affected packages and fixed versions:
- reorder (crates.io): affected all versions; fixed in 1.1.0
- reorder (crates.io): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29941/ (Markdown: https://insights.sbomify.com/CVE-2021-29941/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29941
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29941
- OSV: https://osv.dev/vulnerability/CVE-2021-29941

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29941/
Summaries are generated and may contain mistakes; the official description above is the record.
