{"answers":{"affected":"2 open source packages ship an affected version, including docsify. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-30074 in the wild and no public exploit code.","fix":"Upgrade docsify to 4.12.2 or later.","what":"CVE-2021-30074 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-30074 and fix it if it is affected.\n\nWhat it is: CVE-2021-30074 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-30074 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- docsify (npm): affected all versions; fixed in 4.12.2\n- docsify (npm): affected all versions; fixed in 4.12.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-30074/ (Markdown: https://insights.sbomify.com/CVE-2021-30074/index.md)","id":"CVE-2021-30074","markdown":"https://insights.sbomify.com/CVE-2021-30074/index.md","name":"CVE-2021-30074","record":{"aliases":["GHSA-5h7x-68wj-jhwc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"docsify documentation library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via XSS in the docsify search component due to improper encoding of code blocks.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"docsify","vendor":"docsifyjs"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"docsify 4.12.1 is affected by Cross Site Scripting (XSS) because the search component does not appropriately encode Code Blocks and mishandles the \" character.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Docsify vulnerable to cross-site scripting due to mishandled encoding","id":"CVE-2021-30074","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":1,"next":{"headline":"Access control bypass in Beego","id":"CVE-2021-30080"},"packages":[{"ecosystem":"npm","fixed":["4.12.2"],"introduced":["0"],"last_affected":[],"package":"docsify","purl":null,"source":"GHSA-5h7x-68wj-jhwc"},{"ecosystem":"npm","fixed":["4.12.2"],"introduced":["0"],"last_affected":[],"package":"docsify","purl":"pkg:npm/docsify","source":"GHSA-5h7x-68wj-jhwc"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2021-30072"},"products":["n/a"],"published":"2021-04-02","related":[{"cvss_score":8.6,"headline":"Cross-site Scripting (XSS)","id":"CVE-2021-23342","kev_date_added":null,"published":"2021-02-19"},{"cvss_score":6.1,"headline":"Cross-site Scripting in docsify","id":"CVE-2020-7680","kev_date_added":null,"published":"2020-07-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts via XSS in the docsify search component due to improper encoding of code blocks.","url":"https://insights.sbomify.com/CVE-2021-30074/"}