{"answers":{"affected":"5 open source packages ship an affected version, including grep-cli and ripgrep. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-3013 in the wild and no public exploit code.","fix":"Upgrade grep-cli to 0.1.6 or later.","what":"CVE-2021-3013 is a critical command injection vulnerability in n/a, published on 11 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-3013 and fix it if it is affected.\n\nWhat it is: CVE-2021-3013 is a critical command injection vulnerability in n/a, published on 11 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-3013 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- grep-cli (crates.io): affected all versions; fixed in 0.1.6\n- grep-cli (crates.io): affected all versions; fixed in 0.1.6\n- grep-cli (crates.io): affected from 0.0.0-0; fixed in 0.1.6\n- ripgrep (crates.io): affected all versions; fixed in 13.0.0\n- ripgrep (crates.io): affected all versions; fixed in 13.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3013/ (Markdown: https://insights.sbomify.com/CVE-2021-3013/index.md)","id":"CVE-2021-3013","markdown":"https://insights.sbomify.com/CVE-2021-3013/index.md","name":"CVE-2021-3013","record":{"aliases":["GHSA-g4xg-fxmg-vcg5","RUSTSEC-2021-0071","UBUNTU-CVE-2021-3013","openSUSE-SU-2024:11300-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"ripgrep search tool","requires_auth":"none","summary":"Attackers can execute arbitrary programs via specific flags in ripgrep on Windows, posing a risk to developers using the tool.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ripgrep","vendor":"ripgrep_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"ripgrep before 13 on Windows allows attackers to trigger execution of arbitrary programs from the current working directory via the -z/--search-zip or --pre flag.","ecosystems":["crates.io","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OS command injection in ripgrep","id":"CVE-2021-3013","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"command_injection","year":"2021"},"n_packages":6,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2021-3014"},"packages":[{"ecosystem":"crates.io","fixed":["0.1.6"],"introduced":["0"],"last_affected":[],"package":"grep-cli","purl":null,"source":"GHSA-g4xg-fxmg-vcg5"},{"ecosystem":"crates.io","fixed":["0.1.6"],"introduced":["0"],"last_affected":[],"package":"grep-cli","purl":"pkg:cargo/grep-cli","source":"GHSA-g4xg-fxmg-vcg5"},{"ecosystem":"crates.io","fixed":["0.1.6"],"introduced":["0.0.0-0"],"last_affected":[],"package":"grep-cli","purl":"pkg:cargo/grep-cli","source":"RUSTSEC-2021-0071"},{"ecosystem":"crates.io","fixed":["13.0.0"],"introduced":["0"],"last_affected":[],"package":"ripgrep","purl":null,"source":"GHSA-g4xg-fxmg-vcg5"},{"ecosystem":"crates.io","fixed":["13.0.0"],"introduced":["0"],"last_affected":[],"package":"ripgrep","purl":"pkg:cargo/ripgrep","source":"GHSA-g4xg-fxmg-vcg5"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["13.0.0-2.2"],"introduced":["0"],"last_affected":[],"package":"ripgrep","purl":"pkg:rpm/opensuse/ripgrep\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11300-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2021-3012"},"products":["n/a"],"published":"2021-06-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can execute arbitrary programs via specific flags in ripgrep on Windows, posing a risk to developers using the tool.","url":"https://insights.sbomify.com/CVE-2021-3013/"}