# CVE-2021-3013: OS command injection in ripgrep

> Attackers can execute arbitrary programs via specific flags in ripgrep on Windows, posing a risk to developers using the tool.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-g4xg-fxmg-vcg5, RUSTSEC-2021-0071, UBUNTU-CVE-2021-3013, openSUSE-SU-2024:11300-1

## What is CVE-2021-3013?

CVE-2021-3013 is a critical command injection vulnerability in n/a, published on 11 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ripgrep before 13 on Windows allows attackers to trigger execution of arbitrary programs from the current working directory via the -z/--search-zip or --pre flag.

## Which versions are affected by CVE-2021-3013?

5 open source packages ship an affected version, including grep-cli and ripgrep. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grep-cli` | crates.io | All versions | 0.1.6 |
| `grep-cli` | crates.io | All versions | 0.1.6 |
| `grep-cli` | crates.io | From 0.0.0-0 | 0.1.6 |
| `ripgrep` | crates.io | All versions | 13.0.0 |
| `ripgrep` | crates.io | All versions | 13.0.0 |
| `ripgrep` | openSUSE:Tumbleweed | All versions | 13.0.0-2.2 |

Products: Ripgrep Project Ripgrep.

## How do I fix CVE-2021-3013?

Upgrade grep-cli to 0.1.6 or later.

## Is CVE-2021-3013 being exploited?

There is no known exploitation of CVE-2021-3013 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3013 and fix it if it is affected.

What it is: CVE-2021-3013 is a critical command injection vulnerability in n/a, published on 11 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3013 in the wild and no public exploit code.

Affected packages and fixed versions:
- grep-cli (crates.io): affected all versions; fixed in 0.1.6
- grep-cli (crates.io): affected all versions; fixed in 0.1.6
- grep-cli (crates.io): affected from 0.0.0-0; fixed in 0.1.6
- ripgrep (crates.io): affected all versions; fixed in 13.0.0
- ripgrep (crates.io): affected all versions; fixed in 13.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3013/ (Markdown: https://insights.sbomify.com/CVE-2021-3013/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3013
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3013
- OSV: https://osv.dev/vulnerability/CVE-2021-3013

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3013/
Summaries are generated and may contain mistakes; the official description above is the record.
