CVE-2021-30130 Improper Certificate Validation in phpseclib

High 7.5 Published Updated

Attackers can bypass RSA PKCS#1 v1.5 signature verification in phpseclib, potentially allowing forged signatures to be accepted as valid.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-30130?

CVE-2021-30130 is a high-severity vulnerability in Debian Debian Linux, published on 6 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.

Weakness: CWE-347

Which versions are affected by CVE-2021-30130?

4 open source packages ship an affected version, including phpseclib/phpseclib. It affects 2 products.

PackageAffectedFixed in
phpseclib/phpseclib PackagistAll versions2.0.31
phpseclib/phpseclib PackagistAll versions2.0.31
phpseclib/phpseclib PackagistFrom 3.0.03.0.7
phpseclib/phpseclib PackagistFrom 3.0.03.0.7

Products include Debian Debian Linux, Phpseclib Phpseclib.

How do I fix CVE-2021-30130?

Upgrade phpseclib/phpseclib to a fixed version for your release line: 2.0.31 or 3.0.7.

Is CVE-2021-30130 being exploited?

There is no known exploitation of CVE-2021-30130 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2021-30130, DLA-3197-1, DLA-3198-1, GHSA-vf4w-fg7r-5v94, UBUNTU-CVE-2021-30130.

Is CVE-2021-30130 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free