# CVE-2021-30134: php-mod/curl allows Cross-site Scripting

> Cross-site scripting vulnerability in php-mod/curl allows attackers to inject malicious scripts via specific parameters, potentially leading to code execution.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Dec 2022
- **Updated:** 14 Apr 2025
- **Also known as:** GHSA-f8p3-q834-q9cj

## What is CVE-2021-30134?

CVE-2021-30134 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

php-mod/curl (a wrapper of the PHP cURL extension) before 2.3.2 allows XSS via the post_file_path_upload.php key parameter and the POST data to post_multidimensional.php.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-30134?

2 open source packages ship an affected version, including php-mod/curl. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `php-mod/curl` | Packagist | All versions | 2.3.2 |
| `php-mod/curl` | Packagist | All versions | 2.3.2 |

Products: Ht Slider Range for Amazon Affiliates Project Ht Slider Range for Amazon Affiliates, Php Curl Class Project Php Curl Class, Ptwooplugins Invoicing With Invoicexpress for Woocommerce, Qiwi Woo-Qiwi-Payment-Gateway, Shopello Api Project Shopello Api, Teamleade Teamleader Crm Forms.

## How do I fix CVE-2021-30134?

Upgrade php-mod/curl to 2.3.2 or later.

## Is CVE-2021-30134 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-30134 exists.

Public exploit code:

- Php-mod/curl Library <2.3.2 - Cross-Site Scripting (nuclei): http/cves/2021/CVE-2021-30134.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-30134 and fix it if it is affected.

What it is: CVE-2021-30134 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-30134 exists.

Affected packages and fixed versions:
- php-mod/curl (Packagist): affected all versions; fixed in 2.3.2
- php-mod/curl (Packagist): affected all versions; fixed in 2.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-30134/ (Markdown: https://insights.sbomify.com/CVE-2021-30134/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-30134
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-30134
- OSV: https://osv.dev/vulnerability/CVE-2021-30134

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-30134/
Summaries are generated and may contain mistakes; the official description above is the record.
