# CVE-2021-30140: Cross-site scripting in n/a

> Stored XSS in LiquidFiles allows attackers to execute malicious scripts in an administrator's browser via crafted file uploads.

- **Severity:** Medium 5.4 (`CVSS:3.1/AC:L/AV:N/A:N/C:L/I:L/PR:L/S:C/UI:R`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 6 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-4f76-8jp4-59r6

## What is CVE-2021-30140?

CVE-2021-30140 is a medium-severity cross-site scripting vulnerability in n/a, published on 6 Apr 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

LiquidFiles 3.4.15 has stored XSS through the "send email" functionality when sending a file via email to an administrator. When a file has no extension and contains malicious HTML / JavaScript content (such as SVG with HTML content), the payload is executed upon a click. This is fixed in 3.5.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-30140?

It affects 1 product.


Products: Liquidfiles Liquidfiles.

## How do I fix CVE-2021-30140?

No fix has been published for CVE-2021-30140 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-30140 being exploited?

There is no known exploitation of CVE-2021-30140 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-46093](https://insights.sbomify.com/CVE-2025-46093/): Privilege escalation in LiquidFiles (critical 9.9)
- [CVE-2020-29071](https://insights.sbomify.com/CVE-2020-29071/): Cross-site scripting in n/a (critical 9.0)
- [CVE-2021-43397](https://insights.sbomify.com/CVE-2021-43397/): LiquidFiles before 3.6.3 allows remote attackers to elevate their privileges from Admin (or User Admin) to Sysadmin. (high 8.8)
- [CVE-2025-56132](https://insights.sbomify.com/CVE-2025-56132/): Information disclosure in n/a (high 7.3)
- [CVE-2020-29072](https://insights.sbomify.com/CVE-2020-29072/): Information disclosure in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-30140 and fix it if it is affected.

What it is: CVE-2021-30140 is a medium-severity cross-site scripting vulnerability in n/a, published on 6 Apr 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-30140 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-30140/ (Markdown: https://insights.sbomify.com/CVE-2021-30140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-30140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-30140
- OSV: https://osv.dev/vulnerability/CVE-2021-30140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-30140/
Summaries are generated and may contain mistakes; the official description above is the record.
