CVE-2021-30152 Privilege escalation in n/a
Attackers can escalate privileges by protecting pages to higher levels than their permissions allow via the MediaWiki API.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-30152?
CVE-2021-30152 is a medium-severity vulnerability in Debian Debian Linux, published on 9 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in MediaWiki before 1.31.13 and 1.32.x through 1.35.x before 1.35.2. When using the MediaWiki API to "protect" a page, a user is currently able to protect to a higher level than they currently have permissions for.
Weakness: CWE-269
Which versions are affected by CVE-2021-30152?
1 open source package ship an affected version, including mediawiki. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.31.13, 1.35.2 |
Products include Debian Debian Linux, Fedoraproject Fedora, Mediawiki Mediawiki.
How do I fix CVE-2021-30152?
Upgrade mediawiki to a fixed version for your release line: 1.31.13 or 1.35.2.
Is CVE-2021-30152 being exploited?
There is no known exploitation of CVE-2021-30152 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-mediawiki-2021-30152, DEBIAN-CVE-2021-30152, GHSA-9q28-h7m9-gwr9, UBUNTU-CVE-2021-30152.