CVE-2021-30154 Cross-site scripting in n/a

Medium 6.1 Published Updated

Cross-site scripting vulnerability in MediaWiki allows attackers to inject malicious scripts via unescaped HTML output on the Special:NewFiles page.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-30154?

CVE-2021-30154 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 6 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

An issue was discovered in MediaWiki before 1.31.12 and 1.32.x through 1.35.x before 1.35.2. On Special:NewFiles, all the mediastatistics-header-* messages are output in HTML unescaped, leading to XSS.

Weakness: CWE-79

Which versions are affected by CVE-2021-30154?

1 open source package ship an affected version, including mediawiki. It affects 3 products.

PackageAffectedFixed in
mediawiki BitnamiAll versions1.31.12, 1.35.2

Products include Debian Debian Linux, Fedoraproject Fedora, Mediawiki Mediawiki.

How do I fix CVE-2021-30154?

Upgrade mediawiki to a fixed version for your release line: 1.31.12 or 1.35.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-30154 being exploited?

There is no known exploitation of CVE-2021-30154 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as BIT-mediawiki-2021-30154, DEBIAN-CVE-2021-30154, GHSA-56c6-mj2h-234g, UBUNTU-CVE-2021-30154.

Is CVE-2021-30154 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free