CVE-2021-30155 Missing authorization in n/a
Attackers can modify the content model of nonexistent pages without proper authorization, potentially altering page behavior or structure.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-30155?
CVE-2021-30155 is a medium-severity missing authorization vulnerability in Debian Debian Linux, published on 9 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in MediaWiki before 1.31.12 and 1.32.x through 1.35.x before 1.35.2. ContentModelChange does not check if a user has correct permissions to create and set the content model of a nonexistent page.
Weakness: CWE-862
Which versions are affected by CVE-2021-30155?
1 open source package ship an affected version, including mediawiki. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.31.12, 1.35.2 |
Products include Debian Debian Linux, Fedoraproject Fedora, Mediawiki Mediawiki.
How do I fix CVE-2021-30155?
Upgrade mediawiki to a fixed version for your release line: 1.31.12 or 1.35.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-30155 being exploited?
There is no known exploitation of CVE-2021-30155 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-mediawiki-2021-30155, DEBIAN-CVE-2021-30155, GHSA-rjh4-5hvf-f2f8.