CVE-2021-30158 Security feature bypass in n/a

Medium 5.3 Published Updated

Blocked users cannot reset compromised tokens, preventing them from securing their accounts against unauthorized access.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-30158?

CVE-2021-30158 is a medium-severity vulnerability in Debian Debian Linux, published on 6 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in MediaWiki before 1.31.12 and 1.32.x through 1.35.x before 1.35.2. Blocked users are unable to use Special:ResetTokens. This has security relevance because a blocked user might have accidentally shared a token, or might know that a token has been compromised, and yet is not able to block any potential future use of the token by an unauthorized party.

Weakness: CWE-287

Which versions are affected by CVE-2021-30158?

1 open source package ship an affected version, including mediawiki. It affects 3 products.

PackageAffectedFixed in
mediawiki BitnamiAll versions1.31.12, 1.35.2

Products include Debian Debian Linux, Fedoraproject Fedora, Mediawiki Mediawiki.

How do I fix CVE-2021-30158?

Upgrade mediawiki to a fixed version for your release line: 1.31.12 or 1.35.2.

Is CVE-2021-30158 being exploited?

There is no known exploitation of CVE-2021-30158 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as BIT-mediawiki-2021-30158, DEBIAN-CVE-2021-30158, GHSA-c7v8-6m32-34m3, UBUNTU-CVE-2021-30158.

Is CVE-2021-30158 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free