# CVE-2021-30158: Security feature bypass in n/a

> Blocked users cannot reset compromised tokens, preventing them from securing their accounts against unauthorized access.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-mediawiki-2021-30158, DEBIAN-CVE-2021-30158, GHSA-c7v8-6m32-34m3, UBUNTU-CVE-2021-30158

## What is CVE-2021-30158?

CVE-2021-30158 is a medium-severity vulnerability in Debian Debian Linux, published on 6 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in MediaWiki before 1.31.12 and 1.32.x through 1.35.x before 1.35.2. Blocked users are unable to use Special:ResetTokens. This has security relevance because a blocked user might have accidentally shared a token, or might know that a token has been compromised, and yet is not able to block any potential future use of the token by an unauthorized party.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2021-30158?

1 open source package ship an affected version, including mediawiki. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.31.12, 1.35.2 |

Products: Debian Debian Linux, Fedoraproject Fedora, Mediawiki Mediawiki.

## How do I fix CVE-2021-30158?

Upgrade mediawiki to a fixed version for your release line: 1.31.12 or 1.35.2.

## Is CVE-2021-30158 being exploited?

There is no known exploitation of CVE-2021-30158 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-30158 and fix it if it is affected.

What it is: CVE-2021-30158 is a medium-severity vulnerability in Debian Debian Linux, published on 6 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-30158 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.31.12, 1.35.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-30158/ (Markdown: https://insights.sbomify.com/CVE-2021-30158/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-30158
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-30158
- OSV: https://osv.dev/vulnerability/CVE-2021-30158

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-30158/
Summaries are generated and may contain mistakes; the official description above is the record.
