CVE-2021-30159 Business logic in n/a
Attackers can bypass page deletion restrictions in MediaWiki by exploiting race conditions during fast double moves, leading to unauthorized data modification.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-30159?
CVE-2021-30159 is a medium-severity vulnerability in Debian Debian Linux, published on 9 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in MediaWiki before 1.31.12 and 1.32.x through 1.35.x before 1.35.2. Users can bypass intended restrictions on deleting pages in certain "fast double move" situations. MovePage::isValidMoveTarget() uses FOR UPDATE, but it's only called if Title::getArticleID() returns non-zero with no special flags. Next, MovePage::moveToInternal() will delete the page if getArticleID(READ_LATEST) is non-zero. Therefore, if the page is missing in the replica DB, isValidMove() will return true, and then moveToInternal() will unconditionally delete the page if it can be found in the master.
Which versions are affected by CVE-2021-30159?
1 open source package ship an affected version, including mediawiki. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.31.12, 1.35.2 |
Products include Debian Debian Linux, Fedoraproject Fedora, Mediawiki Mediawiki.
How do I fix CVE-2021-30159?
Upgrade mediawiki to a fixed version for your release line: 1.31.12 or 1.35.2.
Is CVE-2021-30159 being exploited?
There is no known exploitation of CVE-2021-30159 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-mediawiki-2021-30159, DEBIAN-CVE-2021-30159, GHSA-67j2-jh4p-rj4j, UBUNTU-CVE-2021-30159.