CVE-2021-30164 Missing authorization in n/a
Attackers can bypass permission checks to add notes to issues via the API, allowing unauthorized data modification in Redmine.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-30164?
CVE-2021-30164 is a critical missing authorization vulnerability in Debian Debian Linux, published on 6 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Redmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the add_issue_notes permission requirement by leveraging the Issues API.
Which versions are affected by CVE-2021-30164?
1 open source package ship an affected version, including redmine. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
redmine Bitnami | All versions | 4.0.8, 4.1.2 |
Products include Debian Debian Linux, Redmine Redmine.
How do I fix CVE-2021-30164?
Upgrade redmine to a fixed version for your release line: 4.0.8 or 4.1.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-30164 being exploited?
There is no known exploitation of CVE-2021-30164 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-redmine-2021-30164, DEBIAN-CVE-2021-30164, GHSA-8c7v-26g9-8vwr, UBUNTU-CVE-2021-30164.