# CVE-2021-30164: Missing authorization in n/a

> Attackers can bypass permission checks to add notes to issues via the API, allowing unauthorized data modification in Redmine.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-redmine-2021-30164, DEBIAN-CVE-2021-30164, GHSA-8c7v-26g9-8vwr, UBUNTU-CVE-2021-30164

## What is CVE-2021-30164?

CVE-2021-30164 is a critical missing authorization vulnerability in Debian Debian Linux, published on 6 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Redmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the add_issue_notes permission requirement by leveraging the Issues API.

## Which versions are affected by CVE-2021-30164?

1 open source package ship an affected version, including redmine. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `redmine` | Bitnami | All versions | 4.0.8, 4.1.2 |

Products: Debian Debian Linux, Redmine Redmine.

## How do I fix CVE-2021-30164?

Upgrade redmine to a fixed version for your release line: 4.0.8 or 4.1.2.

## Is CVE-2021-30164 being exploited?

There is no known exploitation of CVE-2021-30164 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-30164 and fix it if it is affected.

What it is: CVE-2021-30164 is a critical missing authorization vulnerability in Debian Debian Linux, published on 6 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-30164 in the wild and no public exploit code.

Affected packages and fixed versions:
- redmine (Bitnami): affected all versions; fixed in 4.0.8, 4.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-30164/ (Markdown: https://insights.sbomify.com/CVE-2021-30164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-30164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-30164
- OSV: https://osv.dev/vulnerability/CVE-2021-30164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-30164/
Summaries are generated and may contain mistakes; the official description above is the record.
