# CVE-2021-30179: Apache Dubbo Pre-auth RCE via Java deserialization in the Generic filter

> An attacker can achieve remote code execution by sending crafted generic calls with nativejava attachments to the GenericFilter.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-5mc7-m686-p6jg

## What is CVE-2021-30179?

CVE-2021-30179 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 31 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Dubbo prior to 2.6.9 and 2.7.9 by default supports generic calls to arbitrary methods exposed by provider interfaces. These invocations are handled by the GenericFilter which will find the service and method specified in the first arguments of the invocation and use the Java Reflection API to make the final call. The signature for the $invoke or $invokeAsync methods is Ljava/lang/String;[Ljava/lang/String;[Ljava/lang/Object; where the first argument is the name of the method to invoke, the second one is an array with the parameter types for the method being invoked and the third one is an array with the actual call arguments. In addition, the caller also needs to set an RPC attachment specifying that the call is a generic call and how to decode the arguments. The possible values are: - true - raw.return - nativejava - bean - protobuf-json An attacker can control this RPC attachment and set it to nativejava to force the java deserialization of the byte array located in the third argument.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-30179?

4 open source packages ship an affected version, including org.apache.dubbo:dubbo and com.alibaba:dubbo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.dubbo:dubbo` | Maven | From 2.5.0 | 2.7.10 |
| `org.apache.dubbo:dubbo` | Maven | From 2.5.0 | 2.7.10 |
| `com.alibaba:dubbo` | Maven | From 2.5.0 | 2.6.9 |
| `com.alibaba:dubbo` | Maven | From 2.5.0 | 2.6.9 |

Products: Apache Dubbo.

## How do I fix CVE-2021-30179?

Upgrade org.apache.dubbo:dubbo to 2.7.10 or later.

## Is CVE-2021-30179 being exploited?

There is no known exploitation of CVE-2021-30179 in the wild and no public exploit code.

## Other vulnerabilities in Apache Dubbo

- [CVE-2023-29234](https://insights.sbomify.com/CVE-2023-29234/): Bypass serialize checks in Apache Dubbo (critical 9.8)
- [CVE-2023-46279](https://insights.sbomify.com/CVE-2023-46279/): Apache Dubbo: Bypass deny serialize list check in Apache Dubbo (critical 9.8)
- [CVE-2021-32824](https://insights.sbomify.com/CVE-2021-32824/): Regular expression Denial of Service in MooTools (critical 9.8)
- [CVE-2022-39198](https://insights.sbomify.com/CVE-2022-39198/): Apache Dubbo Hession Deserialization Vulnerability Gadgets Bypass (critical 9.8)
- [CVE-2021-43297](https://insights.sbomify.com/CVE-2021-43297/): Dubbo Hessian cause RCE when parse error (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-30179 and fix it if it is affected.

What it is: CVE-2021-30179 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 31 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-30179 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.dubbo:dubbo (Maven): affected from 2.5.0; fixed in 2.7.10
- org.apache.dubbo:dubbo (Maven): affected from 2.5.0; fixed in 2.7.10
- com.alibaba:dubbo (Maven): affected from 2.5.0; fixed in 2.6.9
- com.alibaba:dubbo (Maven): affected from 2.5.0; fixed in 2.6.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-30179/ (Markdown: https://insights.sbomify.com/CVE-2021-30179/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-30179
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-30179
- OSV: https://osv.dev/vulnerability/CVE-2021-30179

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-30179/
Summaries are generated and may contain mistakes; the official description above is the record.
