# CVE-2021-30185: Indico Tampering with links (e.g. password reset) in sent emails

> Attackers can manipulate the Host header in password reset links to redirect users to malicious sites, potentially leading to account takeover.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-wgpj-7c2j-vfjm, PYSEC-2021-18

## What is CVE-2021-30185?

CVE-2021-30185 is a high-severity vulnerability in n/a, published on 7 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CERN Indico before 2.3.4 can use an attacker-supplied Host header in a password reset link.

## Which versions are affected by CVE-2021-30185?

3 open source packages ship an affected version, including indico. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `indico` | PyPI | All versions | 2.3.4 |
| `indico` | PyPI | All versions | 2.3.4 |
| `indico` | PyPI | All versions | 2.3.4 |

Products: Cern Indico.

## How do I fix CVE-2021-30185?

Upgrade indico to 2.3.4 or later.

## Is CVE-2021-30185 being exploited?

There is no known exploitation of CVE-2021-30185 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-33046](https://insights.sbomify.com/CVE-2026-33046/): Indico discloses local files resulting in Remote Code Execution through LaTeX injection (high 7.7)
- [CVE-2026-25738](https://insights.sbomify.com/CVE-2026-25738/): Indico has Server-Side Request Forgery (SSRF) in multiple places (medium 6.9)
- [CVE-2026-28352](https://insights.sbomify.com/CVE-2026-28352/): Indico missing access check in event series management API (medium 6.5)
- [CVE-2026-25739](https://insights.sbomify.com/CVE-2026-25739/): Indico affected by Cross-Site-Scripting via material uploads (medium 5.4)
- [CVE-2023-37901](https://insights.sbomify.com/CVE-2023-37901/): Cross-Site-Scripting via confirmation prompts (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-30185 and fix it if it is affected.

What it is: CVE-2021-30185 is a high-severity vulnerability in n/a, published on 7 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-30185 in the wild and no public exploit code.

Affected packages and fixed versions:
- indico (PyPI): affected all versions; fixed in 2.3.4
- indico (PyPI): affected all versions; fixed in 2.3.4
- indico (PyPI): affected all versions; fixed in 2.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-30185/ (Markdown: https://insights.sbomify.com/CVE-2021-30185/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-30185
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-30185
- OSV: https://osv.dev/vulnerability/CVE-2021-30185

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-30185/
Summaries are generated and may contain mistakes; the official description above is the record.
