{"answers":{"affected":"3 open source packages ship an affected version, including outer_cgi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-30454 in the wild and no public exploit code.","fix":"Upgrade outer_cgi to 0.2.1 or later.","what":"CVE-2021-30454 is a critical memory corruption vulnerability in n/a, published on 7 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-30454 and fix it if it is affected.\n\nWhat it is: CVE-2021-30454 is a critical memory corruption vulnerability in n/a, published on 7 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-30454 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- outer_cgi (crates.io): affected all versions; fixed in 0.2.1\n- outer_cgi (crates.io): affected all versions; fixed in 0.2.1\n- outer_cgi (crates.io): affected from 0.0.0-0; fixed in 0.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-30454/ (Markdown: https://insights.sbomify.com/CVE-2021-30454/index.md)","id":"CVE-2021-30454","markdown":"https://insights.sbomify.com/CVE-2021-30454/index.md","name":"CVE-2021-30454","record":{"aliases":["GHSA-6vmq-jh76-hq43","RUSTSEC-2021-0051"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust CGI library","requires_auth":"none","summary":"The outer_cgi Rust library allows attackers to trigger memory corruption via uninitialized buffers, potentially leading to code execution or crashes.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"outer_cgi","vendor":"outer_cgi_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"An issue was discovered in the outer_cgi crate before 0.2.1 for Rust. A user-provided Read instance receives an uninitialized memory buffer from KeyValueReader.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Uninitialized memory access in outer_cgi","id":"CVE-2021-30454","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2021"},"n_packages":3,"n_references":1,"next":{"headline":"Double-free in id-map","id":"CVE-2021-30455"},"packages":[{"ecosystem":"crates.io","fixed":["0.2.1"],"introduced":["0"],"last_affected":[],"package":"outer_cgi","purl":null,"source":"GHSA-6vmq-jh76-hq43"},{"ecosystem":"crates.io","fixed":["0.2.1"],"introduced":["0"],"last_affected":[],"package":"outer_cgi","purl":"pkg:cargo/outer_cgi","source":"GHSA-6vmq-jh76-hq43"},{"ecosystem":"crates.io","fixed":["0.2.1"],"introduced":["0.0.0-0"],"last_affected":[],"package":"outer_cgi","purl":"pkg:cargo/outer_cgi","source":"RUSTSEC-2021-0051"}],"prev":{"headline":"Was determined not a vulnerability.","id":"CVE-2021-30369"},"products":["n/a"],"published":"2021-04-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"The outer_cgi Rust library allows attackers to trigger memory corruption via uninitialized buffers, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2021-30454/"}