# CVE-2021-30454: Uninitialized memory access in outer_cgi

> The outer_cgi Rust library allows attackers to trigger memory corruption via uninitialized buffers, potentially leading to code execution or crashes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-6vmq-jh76-hq43, RUSTSEC-2021-0051

## What is CVE-2021-30454?

CVE-2021-30454 is a critical memory corruption vulnerability in n/a, published on 7 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the outer_cgi crate before 0.2.1 for Rust. A user-provided Read instance receives an uninitialized memory buffer from KeyValueReader.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2021-30454?

3 open source packages ship an affected version, including outer_cgi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `outer_cgi` | crates.io | All versions | 0.2.1 |
| `outer_cgi` | crates.io | All versions | 0.2.1 |
| `outer_cgi` | crates.io | From 0.0.0-0 | 0.2.1 |

Products: Outer Cgi Project Outer Cgi.

## How do I fix CVE-2021-30454?

Upgrade outer_cgi to 0.2.1 or later.

## Is CVE-2021-30454 being exploited?

There is no known exploitation of CVE-2021-30454 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-30454 and fix it if it is affected.

What it is: CVE-2021-30454 is a critical memory corruption vulnerability in n/a, published on 7 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-30454 in the wild and no public exploit code.

Affected packages and fixed versions:
- outer_cgi (crates.io): affected all versions; fixed in 0.2.1
- outer_cgi (crates.io): affected all versions; fixed in 0.2.1
- outer_cgi (crates.io): affected from 0.0.0-0; fixed in 0.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-30454/ (Markdown: https://insights.sbomify.com/CVE-2021-30454/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-30454
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-30454
- OSV: https://osv.dev/vulnerability/CVE-2021-30454

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-30454/
Summaries are generated and may contain mistakes; the official description above is the record.
