{"answers":{"affected":"4 open source packages ship an affected version, including wikimedia/parsoid. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-30458 in the wild and no public exploit code.","fix":"Upgrade wikimedia/parsoid to a fixed version for your release line: 0.11.1 or 0.12.2.","what":"CVE-2021-30458 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-30458 and fix it if it is affected.\n\nWhat it is: CVE-2021-30458 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-30458 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wikimedia/parsoid (Packagist): affected all versions; fixed in 0.11.1\n- wikimedia/parsoid (Packagist): affected all versions; fixed in 0.11.1\n- wikimedia/parsoid (Packagist): affected from 0.12; fixed in 0.12.2\n- wikimedia/parsoid (Packagist): affected from 0.12; fixed in 0.12.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-30458/ (Markdown: https://insights.sbomify.com/CVE-2021-30458/index.md)","id":"CVE-2021-30458","markdown":"https://insights.sbomify.com/CVE-2021-30458/index.md","name":"CVE-2021-30458","record":{"aliases":["DEBIAN-CVE-2021-30458","GHSA-5pqx-77vf-85rw","UBUNTU-CVE-2021-30458"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Wikimedia Parsoid","requires_auth":"none","summary":"An attacker can inject malicious scripts via crafted wikitext in Wikimedia Parsoid, bypassing sanitization to execute arbitrary code in the victim's browser.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"parsoid","vendor":"wikimedia"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2. An attacker can send crafted wikitext that Utils/WTUtils.php will transform by using a \u003cmeta\u003e tag, bypassing sanitization steps, and potentially allowing for XSS.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Wikimedia Parsoid vulnerable to Cross-site Scripting (XSS)","id":"CVE-2021-30458","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":4,"n_references":3,"next":{"headline":"SQL Injection via in django-debug-toolbar","id":"CVE-2021-30459"},"packages":[{"ecosystem":"Packagist","fixed":["0.11.1"],"introduced":["0"],"last_affected":[],"package":"wikimedia/parsoid","purl":null,"source":"GHSA-5pqx-77vf-85rw"},{"ecosystem":"Packagist","fixed":["0.11.1"],"introduced":["0"],"last_affected":[],"package":"wikimedia/parsoid","purl":"pkg:composer/wikimedia/parsoid","source":"GHSA-5pqx-77vf-85rw"},{"ecosystem":"Packagist","fixed":["0.12.2"],"introduced":["0.12"],"last_affected":[],"package":"wikimedia/parsoid","purl":null,"source":"GHSA-5pqx-77vf-85rw"},{"ecosystem":"Packagist","fixed":["0.12.2"],"introduced":["0.12"],"last_affected":[],"package":"wikimedia/parsoid","purl":"pkg:composer/wikimedia/parsoid","source":"GHSA-5pqx-77vf-85rw"}],"prev":{"headline":"Double-free in id-map","id":"CVE-2021-30457"},"products":["n/a"],"published":"2021-04-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"An attacker can inject malicious scripts via crafted wikitext in Wikimedia Parsoid, bypassing sanitization to execute arbitrary code in the victim's browser.","url":"https://insights.sbomify.com/CVE-2021-30458/"}