# CVE-2021-30458: Wikimedia Parsoid vulnerable to Cross-site Scripting (XSS)

> An attacker can inject malicious scripts via crafted wikitext in Wikimedia Parsoid, bypassing sanitization to execute arbitrary code in the victim's browser.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-30458, GHSA-5pqx-77vf-85rw, UBUNTU-CVE-2021-30458

## What is CVE-2021-30458?

CVE-2021-30458 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2. An attacker can send crafted wikitext that Utils/WTUtils.php will transform by using a <meta> tag, bypassing sanitization steps, and potentially allowing for XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-30458?

4 open source packages ship an affected version, including wikimedia/parsoid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wikimedia/parsoid` | Packagist | All versions | 0.11.1 |
| `wikimedia/parsoid` | Packagist | All versions | 0.11.1 |
| `wikimedia/parsoid` | Packagist | From 0.12 | 0.12.2 |
| `wikimedia/parsoid` | Packagist | From 0.12 | 0.12.2 |

Products: Wikimedia Parsoid.

## How do I fix CVE-2021-30458?

Upgrade wikimedia/parsoid to a fixed version for your release line: 0.11.1 or 0.12.2.

## Is CVE-2021-30458 being exploited?

There is no known exploitation of CVE-2021-30458 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-30458 and fix it if it is affected.

What it is: CVE-2021-30458 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-30458 in the wild and no public exploit code.

Affected packages and fixed versions:
- wikimedia/parsoid (Packagist): affected all versions; fixed in 0.11.1
- wikimedia/parsoid (Packagist): affected all versions; fixed in 0.11.1
- wikimedia/parsoid (Packagist): affected from 0.12; fixed in 0.12.2
- wikimedia/parsoid (Packagist): affected from 0.12; fixed in 0.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-30458/ (Markdown: https://insights.sbomify.com/CVE-2021-30458/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-30458
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-30458
- OSV: https://osv.dev/vulnerability/CVE-2021-30458

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-30458/
Summaries are generated and may contain mistakes; the official description above is the record.
