# CVE-2021-30560: Nokogiri has vulnerable dependencies on libxml2 and libxslt

> A remote attacker can exploit heap corruption via a crafted HTML page to potentially execute arbitrary code in Google Chrome.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Aug 2021
- **Updated:** 5 May 2025
- **Also known as:** ALPINE-CVE-2021-30560, AZL-9735, CLEANSTART-2024-LT27910, CLEANSTART-2026-DT55361, CLSA-2025-1761056432, CLSA-2026-1776764746, DEBIAN-CVE-2021-30560, DSA-5216-1, GHSA-59gp-qqm7-cw4j, JLSEC-2026-581, MGASA-2022-0341, OESA-2022-2098, SUSE-SU-2023:0556-1, SUSE-SU-2023:0557-1, SUSE-SU-2023:0680-1, UBUNTU-CVE-2021-30560, openSUSE-SU-2024:12423-1

## What is CVE-2021-30560?

CVE-2021-30560 is a high-severity use after free vulnerability in Debian Debian Linux, published on 3 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Use after free in Blink XSLT in Google Chrome prior to 91.0.4472.164 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2021-30560?

2 open source packages ship an affected version, including nokogiri. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.13.2 |
| `nokogiri` | RubyGems | All versions | 1.13.2 |
| `libxslt` | SUSE:Enterprise Storage 7 | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:Enterprise Storage 7.1 | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:Linux Enterprise Micro 5.1 | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:Linux Enterprise Micro 5.2 | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:Linux Enterprise Micro 5.3 | All versions | 1.1.34-150400.3.3.1 |
| `libxslt` | SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 1.1.34-150400.3.3.1 |
| `libxslt` | SUSE:Linux Enterprise Module for Package Hub 15 SP4 | All versions | 1.1.34-150400.3.3.1 |
| `libxslt` | SUSE:Linux Enterprise Real Time 15 SP3 | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:Linux Enterprise Server 12 SP2-BCL | All versions | 1.1.28-17.15.1 |
| `libxslt` | SUSE:Linux Enterprise Server 12 SP4-ESPOS | All versions | 1.1.28-17.15.1 |
| `libxslt` | SUSE:Linux Enterprise Server 12 SP4-LTSS | All versions | 1.1.28-17.15.1 |
| `libxslt` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 1.1.28-17.15.1 |
| `libxslt` | SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 1.1.28-17.15.1 |
| `libxslt` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 1.1.28-17.15.1 |
| `libxslt` | SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 1.1.28-17.15.1 |
| `libxslt` | SUSE:Manager Proxy 4.2 | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:Manager Server 4.2 | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | SUSE:OpenStack Cloud 9 | All versions | 1.1.28-17.15.1 |
| `libxslt` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.1.28-17.15.1 |
| `libxslt` | openSUSE:Leap 15.4 | All versions | 1.1.34-150400.3.3.1 |
| `libxslt-python` | openSUSE:Leap 15.4 | All versions | 1.1.32-150000.3.14.1 |
| `libxslt` | openSUSE:Leap Micro 5.3 | All versions | 1.1.34-150400.3.3.1 |
| `libxslt` | openSUSE:Tumbleweed | All versions | 1.1.37-1.1 |

Products: Debian Debian Linux, Google Chrome, Splunk Universal Forwarder, Xmlsoft Libxslt.

## How do I fix CVE-2021-30560?

Upgrade nokogiri to 1.13.2 or later.

## Is CVE-2021-30560 being exploited?

There is no known exploitation of CVE-2021-30560 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-30560 and fix it if it is affected.

What it is: CVE-2021-30560 is a high-severity use after free vulnerability in Debian Debian Linux, published on 3 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-30560 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.13.2
- nokogiri (RubyGems): affected all versions; fixed in 1.13.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-30560/ (Markdown: https://insights.sbomify.com/CVE-2021-30560/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-30560
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-30560
- OSV: https://osv.dev/vulnerability/CVE-2021-30560

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-30560/
Summaries are generated and may contain mistakes; the official description above is the record.
