CVE-2021-30638 An Information Disclosure due to insufficient input validation exists in Apache Tapestry 5.4.0 and later
Attackers can download files from the WEB-INF directory via specially constructed URLs in Apache Tapestry, leading to information disclosure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-30638?
CVE-2021-30638 is a high-severity path traversal vulnerability in Apache Tapestry, published on 27 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Information Exposure vulnerability in context asset handling of Apache Tapestry allows an attacker to download files inside WEB-INF if using a specially-constructed URL. This was caused by an incomplete fix for CVE-2020-13953. This issue affects Apache Tapestry Apache Tapestry 5.4.0 version to Apache Tapestry 5.6.3; Apache Tapestry 5.7.0 version and Apache Tapestry 5.7.1.
Which versions are affected by CVE-2021-30638?
4 open source packages ship an affected version, including org.apache.tapestry:tapestry-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tapestry:tapestry-core Maven | From 5.4.0 | 5.6.4 |
org.apache.tapestry:tapestry-core Maven | From 5.4.0 | 5.6.4 |
org.apache.tapestry:tapestry-core Maven | From 5.7.0 | 5.7.2 |
org.apache.tapestry:tapestry-core Maven | From 5.7.0 | 5.7.2 |
Products include Apache Tapestry.
How do I fix CVE-2021-30638?
Upgrade org.apache.tapestry:tapestry-core to a fixed version for your release line: 5.6.4 or 5.7.2.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2021-30638 being exploited?
There is no known exploitation of CVE-2021-30638 in the wild and no public exploit code.
Other vulnerabilities in Apache Tapestry
- CVE-2022-46366 Apache Tapestry prior to version 4 (EOL) allows RCE though deserialization of untrusted input
- CVE-2021-27850 Bypass of the fix for CVE-2019-0195
- CVE-2020-17531 Deserialization flaw in EOL Tapestry 4.
- CVE-2019-0195 Deserialization of Untrusted Data in Apache Tapestry
- CVE-2019-10071 Timing attack on HMAC signature comparison in Apache Tapestry
Sources
Also known as GHSA-ghm8-mmx7-xvg2.