# CVE-2021-30638: An Information Disclosure due to insufficient input validation exists in Apache Tapestry 5.4.0 and later

> Attackers can download files from the WEB-INF directory via specially constructed URLs in Apache Tapestry, leading to information disclosure.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-ghm8-mmx7-xvg2

## What is CVE-2021-30638?

CVE-2021-30638 is a high-severity path traversal vulnerability in Apache Tapestry, published on 27 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Information Exposure vulnerability in context asset handling of Apache Tapestry allows an attacker to download files inside WEB-INF if using a specially-constructed URL. This was caused by an incomplete fix for CVE-2020-13953. This issue affects Apache Tapestry Apache Tapestry 5.4.0 version to Apache Tapestry 5.6.3; Apache Tapestry 5.7.0 version and Apache Tapestry 5.7.1.

Weakness: CWE-863 (Incorrect Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-30638?

4 open source packages ship an affected version, including org.apache.tapestry:tapestry-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tapestry:tapestry-core` | Maven | From 5.4.0 | 5.6.4 |
| `org.apache.tapestry:tapestry-core` | Maven | From 5.4.0 | 5.6.4 |
| `org.apache.tapestry:tapestry-core` | Maven | From 5.7.0 | 5.7.2 |
| `org.apache.tapestry:tapestry-core` | Maven | From 5.7.0 | 5.7.2 |

Products: Apache Tapestry.

## How do I fix CVE-2021-30638?

Upgrade org.apache.tapestry:tapestry-core to a fixed version for your release line: 5.6.4 or 5.7.2.

## Is CVE-2021-30638 being exploited?

There is no known exploitation of CVE-2021-30638 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tapestry

- [CVE-2022-46366](https://insights.sbomify.com/CVE-2022-46366/): Apache Tapestry prior to version 4 (EOL) allows RCE though deserialization of untrusted input (critical 9.8)
- [CVE-2021-27850](https://insights.sbomify.com/CVE-2021-27850/): Bypass of the fix for CVE-2019-0195 (critical 9.8)
- [CVE-2020-17531](https://insights.sbomify.com/CVE-2020-17531/): Deserialization flaw in EOL Tapestry 4. (critical 9.8)
- [CVE-2019-0195](https://insights.sbomify.com/CVE-2019-0195/): Deserialization of Untrusted Data in Apache Tapestry (critical 9.8)
- [CVE-2019-10071](https://insights.sbomify.com/CVE-2019-10071/): Timing attack on HMAC signature comparison in Apache Tapestry (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-30638 and fix it if it is affected.

What it is: CVE-2021-30638 is a high-severity path traversal vulnerability in Apache Tapestry, published on 27 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-30638 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tapestry:tapestry-core (Maven): affected from 5.4.0; fixed in 5.6.4
- org.apache.tapestry:tapestry-core (Maven): affected from 5.4.0; fixed in 5.6.4
- org.apache.tapestry:tapestry-core (Maven): affected from 5.7.0; fixed in 5.7.2
- org.apache.tapestry:tapestry-core (Maven): affected from 5.7.0; fixed in 5.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-30638/ (Markdown: https://insights.sbomify.com/CVE-2021-30638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-30638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-30638
- OSV: https://osv.dev/vulnerability/CVE-2021-30638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-30638/
Summaries are generated and may contain mistakes; the official description above is the record.
