# CVE-2021-3114: Other in n/a

> The Go standard library's P-224 elliptic curve implementation produces incorrect outputs due to an underflow error, potentially compromising cryptographic operations.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jan 2021
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-79110, AZL-98820, BIT-golang-2021-3114, DEBIAN-CVE-2021-3114, GHSA-gwfm-9vvh-63r3, GO-2021-0235, RHBA-2021:1522, RHSA-2021:0958, UBUNTU-CVE-2021-3114

## What is CVE-2021-3114?

CVE-2021-3114 is a medium-severity vulnerability in Debian Debian Linux, published on 26 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Go before 1.14.14 and 1.15.x before 1.15.7, crypto/elliptic/p224.go can generate incorrect outputs, related to an underflow of the lowest limb during the final complete reduction in the P-224 field.

Weakness: CWE-682 (Incorrect Calculation)

## Which versions are affected by CVE-2021-3114?

2 open source packages ship an affected version, including golang and stdlib. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `golang` | Bitnami | All versions | 1.14.14, 1.15.7 |
| `stdlib` | Go | All versions | 1.14.14, 1.15.7 |
| `ignition` | Red Hat:openshift:4.6::el8 | All versions | 0:2.6.0-7.rhaos4.6.git947598e.el8 |
| `ignition-debuginfo` | Red Hat:openshift:4.6::el8 | All versions | 0:2.6.0-7.rhaos4.6.git947598e.el8 |
| `ignition-debugsource` | Red Hat:openshift:4.6::el8 | All versions | 0:2.6.0-7.rhaos4.6.git947598e.el8 |
| `ignition-validate` | Red Hat:openshift:4.6::el8 | All versions | 0:2.6.0-7.rhaos4.6.git947598e.el8 |
| `ignition-validate-debuginfo` | Red Hat:openshift:4.6::el8 | All versions | 0:2.6.0-7.rhaos4.6.git947598e.el8 |
| `openshift` | Red Hat:openshift:4.7::el7 | All versions | 0:4.7.0-202103181538.p0.git.97109.7576cdc.el7 |
| `openshift-clients` | Red Hat:openshift:4.7::el7 | All versions | 0:4.7.0-202103191426.p0.git.3953.f3a7513.el7 |
| `openshift-clients-redistributable` | Red Hat:openshift:4.7::el7 | All versions | 0:4.7.0-202103191426.p0.git.3953.f3a7513.el7 |
| `openshift-hyperkube` | Red Hat:openshift:4.7::el7 | All versions | 0:4.7.0-202103181538.p0.git.97109.7576cdc.el7 |
| `openshift` | Red Hat:openshift:4.7::el8 | All versions | 0:4.7.0-202103181538.p0.git.97109.7576cdc.el8 |
| `openshift-clients` | Red Hat:openshift:4.7::el8 | All versions | 0:4.7.0-202103191426.p0.git.3953.f3a7513.el8 |
| `openshift-clients-redistributable` | Red Hat:openshift:4.7::el8 | All versions | 0:4.7.0-202103191426.p0.git.3953.f3a7513.el8 |
| `openshift-hyperkube` | Red Hat:openshift:4.7::el8 | All versions | 0:4.7.0-202103181538.p0.git.97109.7576cdc.el8 |

Products: Debian Debian Linux, Fedoraproject Fedora, Golang Go, Netapp Cloud Insights Telegraf Agent, Netapp Storagegrid.

## How do I fix CVE-2021-3114?

Upgrade golang to a fixed version for your release line: 1.14.14 or 1.15.7.

## Is CVE-2021-3114 being exploited?

There is no known exploitation of CVE-2021-3114 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3114 and fix it if it is affected.

What it is: CVE-2021-3114 is a medium-severity vulnerability in Debian Debian Linux, published on 26 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3114 in the wild and no public exploit code.

Affected packages and fixed versions:
- golang (Bitnami): affected all versions; fixed in 1.14.14, 1.15.7
- stdlib (Go): affected all versions; fixed in 1.14.14, 1.15.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3114/ (Markdown: https://insights.sbomify.com/CVE-2021-3114/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3114
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3114
- OSV: https://osv.dev/vulnerability/CVE-2021-3114

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3114/
Summaries are generated and may contain mistakes; the official description above is the record.
