# CVE-2021-31153: File exposure in pleaser

> A local unprivileged attacker can determine the existence of files or directories in privileged locations using the please library.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-31153, GHSA-f3fg-5j9p-vchc, RUSTSEC-2021-0104

## What is CVE-2021-31153?

CVE-2021-31153 is a low-severity vulnerability in n/a, published on 27 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

please before 0.4 allows a local unprivileged attacker to gain knowledge about the existence of files or directories in privileged locations via the search_path function, the --check option, or the -d option.

## Which versions are affected by CVE-2021-31153?

3 open source packages ship an affected version, including pleaser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pleaser` | crates.io | All versions | 0.4.0 |
| `pleaser` | crates.io | All versions | 0.4.0 |
| `pleaser` | crates.io | From 0.0.0-0 | 0.4.0 |

Products: Please Project Please.

## How do I fix CVE-2021-31153?

Upgrade pleaser to 0.4.0 or later.

## Is CVE-2021-31153 being exploited?

There is no known exploitation of CVE-2021-31153 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31153 and fix it if it is affected.

What it is: CVE-2021-31153 is a low-severity vulnerability in n/a, published on 27 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-31153 in the wild and no public exploit code.

Affected packages and fixed versions:
- pleaser (crates.io): affected all versions; fixed in 0.4.0
- pleaser (crates.io): affected all versions; fixed in 0.4.0
- pleaser (crates.io): affected from 0.0.0-0; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31153/ (Markdown: https://insights.sbomify.com/CVE-2021-31153/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31153
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31153
- OSV: https://osv.dev/vulnerability/CVE-2021-31153

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31153/
Summaries are generated and may contain mistakes; the official description above is the record.
