# CVE-2021-3116: Logic error in authentication in proxy.py

> An attacker can bypass proxy authentication by sending incorrect Proxy-Authorization headers due to a boolean logic error in the proxy.py library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jan 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-cmc7-mfmr-xqrx, PYSEC-2021-46

## What is CVE-2021-3116?

CVE-2021-3116 is a high-severity authentication bypass vulnerability in n/a, published on 11 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

before_upstream_connection in AuthPlugin in http/proxy/auth.py in proxy.py before 2.3.1 accepts incorrect Proxy-Authorization header data because of a boolean confusion (and versus or).

Weakness: CWE-697 (Incorrect Comparison)

## Which versions are affected by CVE-2021-3116?

3 open source packages ship an affected version, including proxy-py and proxy.py. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `proxy-py` | PyPI | All versions | 2.3.1 |
| `proxy-py` | PyPI | All versions | 2.3.1 |
| `proxy.py` | PyPI | All versions | 2.3.1 |

Products: Proxy.py Project Proxy.py.

## How do I fix CVE-2021-3116?

Upgrade proxy-py to 2.3.1 or later.

## Is CVE-2021-3116 being exploited?

There is no known exploitation of CVE-2021-3116 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3116 and fix it if it is affected.

What it is: CVE-2021-3116 is a high-severity authentication bypass vulnerability in n/a, published on 11 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3116 in the wild and no public exploit code.

Affected packages and fixed versions:
- proxy-py (PyPI): affected all versions; fixed in 2.3.1
- proxy-py (PyPI): affected all versions; fixed in 2.3.1
- proxy.py (PyPI): affected all versions; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3116/ (Markdown: https://insights.sbomify.com/CVE-2021-3116/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3116
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3116
- OSV: https://osv.dev/vulnerability/CVE-2021-3116

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3116/
Summaries are generated and may contain mistakes; the official description above is the record.
