# CVE-2021-31164: Apache Unomi log injection

> Attackers can inject CRLF characters into logs due to missing escaping, potentially corrupting log files or misleading log analysis.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-rm7f-mpcj-w4f6

## What is CVE-2021-31164?

CVE-2021-31164 is a high-severity vulnerability in Apache Unomi, published on 4 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Unomi prior to version 1.5.5 allows CRLF log injection because of the lack of escaping in the log statements.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2021-31164?

2 open source packages ship an affected version, including org.apache.unomi:unomi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.unomi:unomi` | Maven | All versions | 1.5.5 |
| `org.apache.unomi:unomi` | Maven | All versions | 1.5.5 |

Products: Apache Unomi.

## How do I fix CVE-2021-31164?

Upgrade org.apache.unomi:unomi to 1.5.5 or later.

## Is CVE-2021-31164 being exploited?

There is no known exploitation of CVE-2021-31164 in the wild and no public exploit code.

## Other vulnerabilities in Apache Unomi

- [CVE-2020-13942](https://insights.sbomify.com/CVE-2020-13942/): Remote Code Execution in Apache Unomi (critical 9.8)
- [CVE-2020-11975](https://insights.sbomify.com/CVE-2020-11975/): Improper Input Validation in Apache Unomi (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31164 and fix it if it is affected.

What it is: CVE-2021-31164 is a high-severity vulnerability in Apache Unomi, published on 4 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-31164 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.unomi:unomi (Maven): affected all versions; fixed in 1.5.5
- org.apache.unomi:unomi (Maven): affected all versions; fixed in 1.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31164/ (Markdown: https://insights.sbomify.com/CVE-2021-31164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31164
- OSV: https://osv.dev/vulnerability/CVE-2021-31164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31164/
Summaries are generated and may contain mistakes; the official description above is the record.
