# CVE-2021-3127: nats-io/jwt not enforcing checking of Import token permissions

> Attackers can bypass access controls in NATS Server due to mishandled Import Token bindings, potentially gaining unauthorized access to resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-nats-2021-3127, DEBIAN-CVE-2021-3127, GHSA-62mh-w5cv-p88c, GHSA-9r5x-fjv3-q6h4, GHSA-j756-f273-xhp4, GO-2022-0386, UBUNTU-CVE-2021-3127

## What is CVE-2021-3127?

CVE-2021-3127 is a high-severity missing authorization vulnerability in n/a, published on 16 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NATS Server 2.x before 2.2.0 and JWT library before 2.0.1 have Incorrect Access Control because Import Token bindings are mishandled.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2021-3127?

15 open source packages ship an affected version, including github.com/nats-io/jwt, nats and github.com/nats-io/jwt/v2. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nats-io/jwt` | Go | All versions to 1.2.2 | None |
| `github.com/nats-io/jwt` | Go | All versions to 1.2.2 | None |
| `github.com/nats-io/jwt` | Go | All versions | 1.2.3-0.20210314221642-a826c77dc9d2 |
| `github.com/nats-io/jwt` | Go | All versions | 1.2.3-0.20210314221642-a826c77dc9d2 |
| `github.com/nats-io/jwt` | Go | All versions | 1.2.3-0.20210314221642-a826c77dc9d2 |
| `nats` | Bitnami | From 2.0.0 | 2.2.0 |
| `github.com/nats-io/jwt/v2` | Go | All versions | 2.0.1 |
| `github.com/nats-io/jwt/v2` | Go | All versions | 2.0.1 |
| `github.com/nats-io/jwt/v2` | Go | All versions | 2.0.1 |
| `github.com/nats-io/jwt/v2` | Go | All versions | 2.0.1 |
| `github.com/nats-io/jwt/v2` | Go | All versions | 2.0.1 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.2.0 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.2.0 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.2.0 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.2.0 |

Products: Linuxfoundation Nats-Server, Nats Jwt Library.

## How do I fix CVE-2021-3127?

Upgrade github.com/nats-io/jwt to 1.2.3-0.20210314221642-a826c77dc9d2 or later.

## Is CVE-2021-3127 being exploited?

There is no known exploitation of CVE-2021-3127 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-28357](https://insights.sbomify.com/CVE-2022-28357/): NATS nats-server allows directory traversal via unintended path to a management action (critical 9.8)
- [CVE-2026-58253](https://insights.sbomify.com/CVE-2026-58253/): NATS Server: Route API Auth Bypass (high 8.8)
- [CVE-2022-24450](https://insights.sbomify.com/CVE-2022-24450/): Incorrect Authorization in NATS nats-server (high 8.8)
- [CVE-2026-33216](https://insights.sbomify.com/CVE-2026-33216/): NATS has MQTT plaintext password disclosure (high 8.6)
- [CVE-2026-58207](https://insights.sbomify.com/CVE-2026-58207/): NATS Server: Remote crash via integer overflow in Connz pagination (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3127 and fix it if it is affected.

What it is: CVE-2021-3127 is a high-severity missing authorization vulnerability in n/a, published on 16 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3127 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/nats-io/jwt (Go): affected all versions up to 1.2.2; no fix listed
- github.com/nats-io/jwt (Go): affected all versions up to 1.2.2; no fix listed
- github.com/nats-io/jwt (Go): affected all versions; fixed in 1.2.3-0.20210314221642-a826c77dc9d2
- github.com/nats-io/jwt (Go): affected all versions; fixed in 1.2.3-0.20210314221642-a826c77dc9d2
- github.com/nats-io/jwt (Go): affected all versions; fixed in 1.2.3-0.20210314221642-a826c77dc9d2
- nats (Bitnami): affected from 2.0.0; fixed in 2.2.0
- github.com/nats-io/jwt/v2 (Go): affected all versions; fixed in 2.0.1
- github.com/nats-io/jwt/v2 (Go): affected all versions; fixed in 2.0.1
- github.com/nats-io/jwt/v2 (Go): affected all versions; fixed in 2.0.1
- github.com/nats-io/jwt/v2 (Go): affected all versions; fixed in 2.0.1
- github.com/nats-io/jwt/v2 (Go): affected all versions; fixed in 2.0.1
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3127/ (Markdown: https://insights.sbomify.com/CVE-2021-3127/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3127
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3127
- OSV: https://osv.dev/vulnerability/CVE-2021-3127

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3127/
Summaries are generated and may contain mistakes; the official description above is the record.
