# CVE-2021-3129: Laravel Ignition File Upload

> Unauthenticated attackers can execute arbitrary code in Ignition when Laravel debug mode is enabled, requiring an upgrade to secure the application.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 18 Sep 2023 (CISA KEV), used in ransomware
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2021
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-4qwp-7c67-jmcc

## What is CVE-2021-3129?

CVE-2021-3129 is a critical code injection vulnerability in n/a, published on 12 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ignition before 2.5.2, as used in Laravel and other products, allows unauthenticated remote attackers to execute arbitrary code because of insecure usage of file_get_contents() and file_put_contents(). This is exploitable on sites using debug mode with Laravel before 8.4.2.

## Which versions are affected by CVE-2021-3129?

8 open source packages ship an affected version, including facade/ignition. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `facade/ignition` | Packagist | All versions | 1.6.15 |
| `facade/ignition` | Packagist | All versions | 1.6.15 |
| `facade/ignition` | Packagist | From 1.7.0 | 1.16.14 |
| `facade/ignition` | Packagist | From 1.7.0 | 1.16.14 |
| `facade/ignition` | Packagist | From 2.0.0 | 2.4.2 |
| `facade/ignition` | Packagist | From 2.0.0 | 2.4.2 |
| `facade/ignition` | Packagist | From 2.5.0 | 2.5.2 |
| `facade/ignition` | Packagist | From 2.5.0 | 2.5.2 |

Products: Facade Ignition.

## How do I fix CVE-2021-3129?

Upgrade facade/ignition to a fixed version for your release line: 1.6.15, 1.16.14, 2.4.2 or 2.5.2. US federal agencies must fix it by 9 Oct 2023.

## Is CVE-2021-3129 being exploited?

Yes. Attackers have exploited CVE-2021-3129 in the wild since at least 18 Sep 2023, including in ransomware campaigns.

Public exploit code:

- Exploit for CVE-2021-3129 (github_poc): https://github.com/ambionics/laravel-exploits
- Laravel <= v8.4.2 debug mode: Remote code execution (CVE-2021-3129) (github_poc): https://github.com/zhzyker/CVE-2021-3129
- Laravel RCE Exploit PoC - CVE-2021-3129 (user-friendly with automatic log path detection) (github_poc): https://github.com/joshuavanderpoll/CVE-2021-3129
- Laravel debug rce (github_poc): https://github.com/SNCKER/CVE-2021-3129
- https://github.com/SecPros-Team/laravel-CVE-2021-3129-EXP (github_poc): https://github.com/SecPros-Team/laravel-CVE-2021-3129-EXP
- Exploit for CVE-2021-3129 (github_poc): https://github.com/nth347/CVE-2021-3129_exploit

## Other vulnerabilities in n/a

- [CVE-2021-43996](https://insights.sbomify.com/CVE-2021-43996/): Incorrect Access Control in Ignition (critical 9.8)
- [CVE-2020-13909](https://insights.sbomify.com/CVE-2020-13909/): Critical severity vulnerability in Ignition (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3129 and fix it if it is affected.

What it is: CVE-2021-3129 is a critical code injection vulnerability in n/a, published on 12 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2021-3129 in the wild since at least 18 Sep 2023, including in ransomware campaigns.

Affected packages and fixed versions:
- facade/ignition (Packagist): affected all versions; fixed in 1.6.15
- facade/ignition (Packagist): affected all versions; fixed in 1.6.15
- facade/ignition (Packagist): affected from 1.7.0; fixed in 1.16.14
- facade/ignition (Packagist): affected from 1.7.0; fixed in 1.16.14
- facade/ignition (Packagist): affected from 2.0.0; fixed in 2.4.2
- facade/ignition (Packagist): affected from 2.0.0; fixed in 2.4.2
- facade/ignition (Packagist): affected from 2.5.0; fixed in 2.5.2
- facade/ignition (Packagist): affected from 2.5.0; fixed in 2.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3129/ (Markdown: https://insights.sbomify.com/CVE-2021-3129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3129
- OSV: https://osv.dev/vulnerability/CVE-2021-3129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3129/
Summaries are generated and may contain mistakes; the official description above is the record.
