# CVE-2021-31294: Denial of service in n/a

> A malicious replica can crash the primary Redis server by sending a specific SET command, causing an assertion failure and denial of service.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2023
- **Updated:** 30 Oct 2024
- **Also known as:** BIT-keydb-2021-31294, BIT-redis-2021-31294, BIT-valkey-2021-31294, DEBIAN-CVE-2021-31294, GHSA-g2jg-2qcv-q3h9, UBUNTU-CVE-2021-31294

## What is CVE-2021-31294?

CVE-2021-31294 is a medium-severity denial of service vulnerability in n/a, published on 15 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Redis before 6cbea7d allows a replica to cause an assertion failure in a primary server by sending a non-administrative command (specifically, a SET command). NOTE: this was fixed for Redis 6.2.x and 7.x in 2021. Versions before 6.2 were not intended to have safety guarantees related to this.

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2021-31294?

3 open source packages ship an affected version, including keydb, redis and valkey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keydb` | Bitnami | All versions | 6.2.0 |
| `redis` | Bitnami | All versions | 6.2.0 |
| `valkey` | Bitnami | All versions | 6.2.0 |

Products: Redis Redis.

## How do I fix CVE-2021-31294?

Upgrade keydb to 6.2.0 or later.

## Is CVE-2021-31294 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-31294 exists.

## Other vulnerabilities in n/a

- [CVE-2022-0543](https://insights.sbomify.com/CVE-2022-0543/): Debian-specific Redis Server Lua Sandbox Escape (critical 10.0, exploited in the wild)
- [CVE-2026-23479](https://insights.sbomify.com/CVE-2026-23479/): redis-server use-after-free in unblock client flow may allow remote code execution (high 7.7)
- [CVE-2026-25243](https://insights.sbomify.com/CVE-2026-25243/): redis-server RESTORE invalid memory access may allow remote code execution (high 7.7)
- [CVE-2025-62507](https://insights.sbomify.com/CVE-2025-62507/): Redis: Bug in XACKDEL may lead to stack overflow and potential RCE (high 7.7)
- [CVE-2025-48367](https://insights.sbomify.com/CVE-2025-48367/): Redis DoS Vulnerability due to bad connection error handling (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31294 and fix it if it is affected.

What it is: CVE-2021-31294 is a medium-severity denial of service vulnerability in n/a, published on 15 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-31294 exists.

Affected packages and fixed versions:
- keydb (Bitnami): affected all versions; fixed in 6.2.0
- redis (Bitnami): affected all versions; fixed in 6.2.0
- valkey (Bitnami): affected all versions; fixed in 6.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31294/ (Markdown: https://insights.sbomify.com/CVE-2021-31294/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31294
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31294
- OSV: https://osv.dev/vulnerability/CVE-2021-31294

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31294/
Summaries are generated and may contain mistakes; the official description above is the record.
