# CVE-2021-31402: dio vulnerable to CRLF injection with HTTP method string

> Attackers can inject CRLF characters into HTTP requests via the method string in the Dart dio package, potentially altering request structure.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-9324-jv53-9cc8

## What is CVE-2021-31402?

CVE-2021-31402 is a high-severity vulnerability in n/a, published on 15 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The dio package 4.0.0 for Dart allows CRLF injection if the attacker controls the HTTP method string, a different vulnerability than CVE-2020-35669.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2021-31402?

2 open source packages ship an affected version, including dio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dio` | Pub | All versions | 5.0.0 |
| `dio` | Pub | All versions | 5.0.0 |

Products: Flutterchina Dio.

## How do I fix CVE-2021-31402?

Upgrade dio to 5.0.0 or later.

## Is CVE-2021-31402 being exploited?

There is no known exploitation of CVE-2021-31402 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31402 and fix it if it is affected.

What it is: CVE-2021-31402 is a high-severity vulnerability in n/a, published on 15 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-31402 in the wild and no public exploit code.

Affected packages and fixed versions:
- dio (Pub): affected all versions; fixed in 5.0.0
- dio (Pub): affected all versions; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31402/ (Markdown: https://insights.sbomify.com/CVE-2021-31402/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31402
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31402
- OSV: https://osv.dev/vulnerability/CVE-2021-31402

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31402/
Summaries are generated and may contain mistakes; the official description above is the record.
