# CVE-2021-31403: Timing side channel vulnerability in UIDL request handler in Vaadin 7 and 8

> Attackers can bypass CSRF protection by guessing security tokens via timing side-channel attacks in the UIDL request handler.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-75xc-qvxh-27f8

## What is CVE-2021-31403?

CVE-2021-31403 is a medium-severity vulnerability in Vaadin, published on 23 Apr 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Non-constant-time comparison of CSRF tokens in UIDL request handler in com.vaadin:vaadin-server versions 7.0.0 through 7.7.23 (Vaadin 7.0.0 through 7.7.23), and 8.0.0 through 8.12.2 (Vaadin 8.0.0 through 8.12.2) allows attacker to guess a security token via timing attack

Weakness: CWE-203 (Observable Discrepancy), CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2021-31403?

8 open source packages ship an affected version, including com.vaadin:vaadin-bom and com.vaadin:vaadin-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:vaadin-bom` | Maven | From 7.0.0 | 7.7.24 |
| `com.vaadin:vaadin-bom` | Maven | From 7.0.0 | 7.7.24 |
| `com.vaadin:vaadin-bom` | Maven | From 8.0.0 | 8.12.3 |
| `com.vaadin:vaadin-bom` | Maven | From 8.0.0 | 8.12.3 |
| `com.vaadin:vaadin-server` | Maven | From 7.0.0 | 7.7.24 |
| `com.vaadin:vaadin-server` | Maven | From 7.0.0 | 7.7.24 |
| `com.vaadin:vaadin-server` | Maven | From 8.0.0 | 8.12.3 |
| `com.vaadin:vaadin-server` | Maven | From 8.0.0 | 8.12.3 |

Products: Vaadin Vaadin.

## How do I fix CVE-2021-31403?

Upgrade com.vaadin:vaadin-bom to a fixed version for your release line: 7.7.24 or 8.12.3.

## Is CVE-2021-31403 being exploited?

There is no known exploitation of CVE-2021-31403 in the wild and no public exploit code.

## Other vulnerabilities in Vaadin

- [CVE-2021-31409](https://insights.sbomify.com/CVE-2021-31409/): Server session is not invalidated when logout() helper method of Authentication module is used in Vaadin 18-19 (high 7.5)
- [CVE-2020-36320](https://insights.sbomify.com/CVE-2020-36320/): Regular expression Denial of Service (ReDoS) in EmailValidator class in Vaadin 7 (high 7.5)
- [CVE-2021-33611](https://insights.sbomify.com/CVE-2021-33611/): Reflected cross-site scripting in vaadin-menu-bar webjar resources in Vaadin 14 (medium 6.1)
- [CVE-2023-25499](https://insights.sbomify.com/CVE-2023-25499/): Possible information disclosure in non visible components (medium 5.7)
- [CVE-2022-29567](https://insights.sbomify.com/CVE-2022-29567/): Possible information disclosure inside TreeGrid component with default data provider (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31403 and fix it if it is affected.

What it is: CVE-2021-31403 is a medium-severity vulnerability in Vaadin, published on 23 Apr 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-31403 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:vaadin-bom (Maven): affected from 7.0.0; fixed in 7.7.24
- com.vaadin:vaadin-bom (Maven): affected from 7.0.0; fixed in 7.7.24
- com.vaadin:vaadin-bom (Maven): affected from 8.0.0; fixed in 8.12.3
- com.vaadin:vaadin-bom (Maven): affected from 8.0.0; fixed in 8.12.3
- com.vaadin:vaadin-server (Maven): affected from 7.0.0; fixed in 7.7.24
- com.vaadin:vaadin-server (Maven): affected from 7.0.0; fixed in 7.7.24
- com.vaadin:vaadin-server (Maven): affected from 8.0.0; fixed in 8.12.3
- com.vaadin:vaadin-server (Maven): affected from 8.0.0; fixed in 8.12.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31403/ (Markdown: https://insights.sbomify.com/CVE-2021-31403/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31403
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31403
- OSV: https://osv.dev/vulnerability/CVE-2021-31403

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31403/
Summaries are generated and may contain mistakes; the official description above is the record.
