# CVE-2021-31405: Regular expression denial of service (ReDoS) in EmailField component in Vaadin 14 and 15-17

> Attackers can cause denial of service in Vaadin applications by submitting malicious email addresses to the EmailField component.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2021
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-2wqp-jmcc-mc77

## What is CVE-2021-31405?

CVE-2021-31405 is a high-severity denial of service vulnerability in Vaadin, published on 23 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Unsafe validation RegEx in EmailField component in com.vaadin:vaadin-text-field-flow versions 2.0.4 through 2.3.2 (Vaadin 14.0.6 through 14.4.3), and 3.0.0 through 4.0.2 (Vaadin 15.0.0 through 17.0.10) allows attackers to cause uncontrolled resource consumption by submitting malicious email addresses.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-31405?

4 open source packages ship an affected version, including com.vaadin:vaadin-bom. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:vaadin-bom` | Maven | From 14.0.6 | 14.4.4 |
| `com.vaadin:vaadin-bom` | Maven | From 14.0.6 | 14.4.4 |
| `com.vaadin:vaadin-bom` | Maven | From 15.0.0 | 17.0.11 |
| `com.vaadin:vaadin-bom` | Maven | From 15.0.0 | 17.0.11 |

Products: Vaadin Flow, Vaadin Vaadin.

## How do I fix CVE-2021-31405?

Upgrade com.vaadin:vaadin-bom to a fixed version for your release line: 14.4.4 or 17.0.11.

## Is CVE-2021-31405 being exploited?

There is no known exploitation of CVE-2021-31405 in the wild and no public exploit code.

## Other vulnerabilities in Vaadin

- [CVE-2021-31407](https://insights.sbomify.com/CVE-2021-31407/): Server classes and resources exposure in OSGi applications using Vaadin 12-14 and 19 (high 8.6)
- [CVE-2021-31411](https://insights.sbomify.com/CVE-2021-31411/): Insecure temporary directory usage in frontend build functionality of Vaadin 14 and 15-19 (medium 6.3)
- [CVE-2021-31408](https://insights.sbomify.com/CVE-2021-31408/): Server session is not invalidated when logout() helper method of Authentication module is used in Vaadin 18-19 (medium 6.3)
- [CVE-2019-25027](https://insights.sbomify.com/CVE-2019-25027/): Reflected cross-site scripting in default RouteNotFoundError view in Vaadin 10 and 11-13 (medium 6.1)
- [CVE-2020-36321](https://insights.sbomify.com/CVE-2020-36321/): Directory traversal in development mode handler in Vaadin 14 and 15-17 (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31405 and fix it if it is affected.

What it is: CVE-2021-31405 is a high-severity denial of service vulnerability in Vaadin, published on 23 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-31405 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:vaadin-bom (Maven): affected from 14.0.6; fixed in 14.4.4
- com.vaadin:vaadin-bom (Maven): affected from 14.0.6; fixed in 14.4.4
- com.vaadin:vaadin-bom (Maven): affected from 15.0.0; fixed in 17.0.11
- com.vaadin:vaadin-bom (Maven): affected from 15.0.0; fixed in 17.0.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31405/ (Markdown: https://insights.sbomify.com/CVE-2021-31405/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31405
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31405
- OSV: https://osv.dev/vulnerability/CVE-2021-31405

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31405/
Summaries are generated and may contain mistakes; the official description above is the record.
