CVE-2021-31407 Server classes and resources exposure in OSGi applications using Vaadin 12-14 and 19

High 8.6 Published Updated

Attackers can access server-side application classes and resources via crafted HTTP requests in Vaadin OSGi integrations.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-31407?

CVE-2021-31407 is a high-severity vulnerability in Vaadin, published on 23 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Vulnerability in OSGi integration in com.vaadin:flow-server versions 1.2.0 through 2.4.7 (Vaadin 12.0.0 through 14.4.9), and 6.0.0 through 6.0.1 (Vaadin 19.0.0) allows attacker to access application classes and resources on the server via crafted HTTP request.

Weakness: CWE-668, CWE-402

Which versions are affected by CVE-2021-31407?

4 open source packages ship an affected version, including com.vaadin:flow-server. It affects 2 products.

PackageAffectedFixed in
com.vaadin:flow-server MavenFrom 1.2.02.4.8
com.vaadin:flow-server MavenFrom 1.2.02.4.8
com.vaadin:flow-server MavenFrom 6.0.06.0.1
com.vaadin:flow-server MavenFrom 6.0.06.0.1

Products include Vaadin Flow, Vaadin Vaadin.

How do I fix CVE-2021-31407?

Upgrade com.vaadin:flow-server to a fixed version for your release line: 2.4.8 or 6.0.1.

Is CVE-2021-31407 being exploited?

There is no known exploitation of CVE-2021-31407 in the wild and no public exploit code.

Sources

Also known as GHSA-25xc-jwfq-39jw.

Is CVE-2021-31407 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free