# CVE-2021-31407: Server classes and resources exposure in OSGi applications using Vaadin 12-14 and 19

> Attackers can access server-side application classes and resources via crafted HTTP requests in Vaadin OSGi integrations.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-25xc-jwfq-39jw

## What is CVE-2021-31407?

CVE-2021-31407 is a high-severity vulnerability in Vaadin, published on 23 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in OSGi integration in com.vaadin:flow-server versions 1.2.0 through 2.4.7 (Vaadin 12.0.0 through 14.4.9), and 6.0.0 through 6.0.1 (Vaadin 19.0.0) allows attacker to access application classes and resources on the server via crafted HTTP request.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-402 (Transmission of Private Resources into a New Sphere)

## Which versions are affected by CVE-2021-31407?

4 open source packages ship an affected version, including com.vaadin:flow-server. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:flow-server` | Maven | From 1.2.0 | 2.4.8 |
| `com.vaadin:flow-server` | Maven | From 1.2.0 | 2.4.8 |
| `com.vaadin:flow-server` | Maven | From 6.0.0 | 6.0.1 |
| `com.vaadin:flow-server` | Maven | From 6.0.0 | 6.0.1 |

Products: Vaadin Flow, Vaadin Vaadin.

## How do I fix CVE-2021-31407?

Upgrade com.vaadin:flow-server to a fixed version for your release line: 2.4.8 or 6.0.1.

## Is CVE-2021-31407 being exploited?

There is no known exploitation of CVE-2021-31407 in the wild and no public exploit code.

## Other vulnerabilities in Vaadin

- [CVE-2021-31405](https://insights.sbomify.com/CVE-2021-31405/): Regular expression denial of service (ReDoS) in EmailField component in Vaadin 14 and 15-17 (high 7.5)
- [CVE-2021-31411](https://insights.sbomify.com/CVE-2021-31411/): Insecure temporary directory usage in frontend build functionality of Vaadin 14 and 15-19 (medium 6.3)
- [CVE-2021-31408](https://insights.sbomify.com/CVE-2021-31408/): Server session is not invalidated when logout() helper method of Authentication module is used in Vaadin 18-19 (medium 6.3)
- [CVE-2019-25027](https://insights.sbomify.com/CVE-2019-25027/): Reflected cross-site scripting in default RouteNotFoundError view in Vaadin 10 and 11-13 (medium 6.1)
- [CVE-2020-36321](https://insights.sbomify.com/CVE-2020-36321/): Directory traversal in development mode handler in Vaadin 14 and 15-17 (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31407 and fix it if it is affected.

What it is: CVE-2021-31407 is a high-severity vulnerability in Vaadin, published on 23 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-31407 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:flow-server (Maven): affected from 1.2.0; fixed in 2.4.8
- com.vaadin:flow-server (Maven): affected from 1.2.0; fixed in 2.4.8
- com.vaadin:flow-server (Maven): affected from 6.0.0; fixed in 6.0.1
- com.vaadin:flow-server (Maven): affected from 6.0.0; fixed in 6.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31407/ (Markdown: https://insights.sbomify.com/CVE-2021-31407/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31407
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31407
- OSV: https://osv.dev/vulnerability/CVE-2021-31407

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31407/
Summaries are generated and may contain mistakes; the official description above is the record.
