# CVE-2021-31411: Insecure temporary directory usage in frontend build functionality of Vaadin 14 and 15-19

> Local attackers can inject malicious code into frontend resources during application rebuilds due to insecure temporary directory usage in Vaadin flow-server.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-p826-8vhq-h439

## What is CVE-2021-31411?

CVE-2021-31411 is a medium-severity code injection vulnerability in Vaadin, published on 5 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Insecure temporary directory usage in frontend build functionality of com.vaadin:flow-server versions 2.0.9 through 2.5.2 (Vaadin 14.0.3 through Vaadin 14.5.2), 3.0 prior to 6.0 (Vaadin 15 prior to 19), and 6.0.0 through 6.0.5 (Vaadin 19.0.0 through 19.0.4) allows local users to inject malicious code into frontend resources during application rebuilds.

Weakness: CWE-379 (Creation of Temporary File in Directory with Insecure Permissions)

## Which versions are affected by CVE-2021-31411?

4 open source packages ship an affected version, including com.vaadin:vaadin-bom. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:vaadin-bom` | Maven | From 14.0.3 | 14.5.3 |
| `com.vaadin:vaadin-bom` | Maven | From 14.0.3 | 14.5.3 |
| `com.vaadin:vaadin-bom` | Maven | From 15.0.0 | 19.0.5 |
| `com.vaadin:vaadin-bom` | Maven | From 15.0.0 | 19.0.5 |

Products: Vaadin Flow, Vaadin Vaadin.

## How do I fix CVE-2021-31411?

Upgrade com.vaadin:vaadin-bom to a fixed version for your release line: 14.5.3 or 19.0.5.

## Is CVE-2021-31411 being exploited?

There is no known exploitation of CVE-2021-31411 in the wild and no public exploit code.

## Other vulnerabilities in Vaadin

- [CVE-2021-31407](https://insights.sbomify.com/CVE-2021-31407/): Server classes and resources exposure in OSGi applications using Vaadin 12-14 and 19 (high 8.6)
- [CVE-2021-31405](https://insights.sbomify.com/CVE-2021-31405/): Regular expression denial of service (ReDoS) in EmailField component in Vaadin 14 and 15-17 (high 7.5)
- [CVE-2021-31408](https://insights.sbomify.com/CVE-2021-31408/): Server session is not invalidated when logout() helper method of Authentication module is used in Vaadin 18-19 (medium 6.3)
- [CVE-2019-25027](https://insights.sbomify.com/CVE-2019-25027/): Reflected cross-site scripting in default RouteNotFoundError view in Vaadin 10 and 11-13 (medium 6.1)
- [CVE-2020-36321](https://insights.sbomify.com/CVE-2020-36321/): Directory traversal in development mode handler in Vaadin 14 and 15-17 (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31411 and fix it if it is affected.

What it is: CVE-2021-31411 is a medium-severity code injection vulnerability in Vaadin, published on 5 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-31411 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:vaadin-bom (Maven): affected from 14.0.3; fixed in 14.5.3
- com.vaadin:vaadin-bom (Maven): affected from 14.0.3; fixed in 14.5.3
- com.vaadin:vaadin-bom (Maven): affected from 15.0.0; fixed in 19.0.5
- com.vaadin:vaadin-bom (Maven): affected from 15.0.0; fixed in 19.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31411/ (Markdown: https://insights.sbomify.com/CVE-2021-31411/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31411
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31411
- OSV: https://osv.dev/vulnerability/CVE-2021-31411

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31411/
Summaries are generated and may contain mistakes; the official description above is the record.
