# CVE-2021-31412: Possible route enumeration in production mode via RouteNotFoundError view in Vaadin 10, 11-14, and 15-19

> Attackers can enumerate application routes via crafted requests in production mode if no custom error handler is configured.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-qrg9-f472-qwfm

## What is CVE-2021-31412?

CVE-2021-31412 is a medium-severity vulnerability in Vaadin, published on 24 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper sanitization of path in default RouteNotFoundError view in com.vaadin:flow-server versions 1.0.0 through 1.0.14 (Vaadin 10.0.0 through 10.0.18), 1.1.0 prior to 2.0.0 (Vaadin 11 prior to 14), 2.0.0 through 2.6.1 (Vaadin 14.0.0 through 14.6.1), and 3.0.0 through 6.0.9 (Vaadin 15.0.0 through 19.0.8) allows network attacker to enumerate all available routes via crafted HTTP request when application is running in production mode and no custom handler for NotFoundException is provided.

Weakness: CWE-20 (Improper Input Validation), CWE-1295 (Debug Messages Revealing Unnecessary Information)

## Which versions are affected by CVE-2021-31412?

6 open source packages ship an affected version, including com.vaadin:vaadin-bom. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:vaadin-bom` | Maven | From 10.0.0 | 10.0.19 |
| `com.vaadin:vaadin-bom` | Maven | From 10.0.0 | 10.0.19 |
| `com.vaadin:vaadin-bom` | Maven | From 11.0.0 | 14.6.2 |
| `com.vaadin:vaadin-bom` | Maven | From 11.0.0 | 14.6.2 |
| `com.vaadin:vaadin-bom` | Maven | From 15.0.0 | 19.0.9 |
| `com.vaadin:vaadin-bom` | Maven | From 15.0.0 | 19.0.9 |

Products: Vaadin Flow, Vaadin Vaadin.

## How do I fix CVE-2021-31412?

Upgrade com.vaadin:vaadin-bom to a fixed version for your release line: 10.0.19, 14.6.2 or 19.0.9.

## Is CVE-2021-31412 being exploited?

There is no known exploitation of CVE-2021-31412 in the wild and no public exploit code.

## Other vulnerabilities in Vaadin

- [CVE-2021-31407](https://insights.sbomify.com/CVE-2021-31407/): Server classes and resources exposure in OSGi applications using Vaadin 12-14 and 19 (high 8.6)
- [CVE-2021-31405](https://insights.sbomify.com/CVE-2021-31405/): Regular expression denial of service (ReDoS) in EmailField component in Vaadin 14 and 15-17 (high 7.5)
- [CVE-2021-31411](https://insights.sbomify.com/CVE-2021-31411/): Insecure temporary directory usage in frontend build functionality of Vaadin 14 and 15-19 (medium 6.3)
- [CVE-2021-31408](https://insights.sbomify.com/CVE-2021-31408/): Server session is not invalidated when logout() helper method of Authentication module is used in Vaadin 18-19 (medium 6.3)
- [CVE-2019-25027](https://insights.sbomify.com/CVE-2019-25027/): Reflected cross-site scripting in default RouteNotFoundError view in Vaadin 10 and 11-13 (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31412 and fix it if it is affected.

What it is: CVE-2021-31412 is a medium-severity vulnerability in Vaadin, published on 24 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-31412 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:vaadin-bom (Maven): affected from 10.0.0; fixed in 10.0.19
- com.vaadin:vaadin-bom (Maven): affected from 10.0.0; fixed in 10.0.19
- com.vaadin:vaadin-bom (Maven): affected from 11.0.0; fixed in 14.6.2
- com.vaadin:vaadin-bom (Maven): affected from 11.0.0; fixed in 14.6.2
- com.vaadin:vaadin-bom (Maven): affected from 15.0.0; fixed in 19.0.9
- com.vaadin:vaadin-bom (Maven): affected from 15.0.0; fixed in 19.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31412/ (Markdown: https://insights.sbomify.com/CVE-2021-31412/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31412
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31412
- OSV: https://osv.dev/vulnerability/CVE-2021-31412

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31412/
Summaries are generated and may contain mistakes; the official description above is the record.
