CVE-2021-31522 Apache Kylin unsafe class loading

Critical 9.8 Published Updated

Attacker can execute arbitrary code via unsafe class loading in Apache Kylin, requiring immediate upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-31522?

CVE-2021-31522 is a critical code injection vulnerability in Apache Kylin, published on 6 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Kylin can receive user input and load any class through Class.forName(...). This issue affects Apache Kylin 2 version 2.6.6 and prior versions; Apache Kylin 3 version 3.1.2 and prior versions; Apache Kylin 4 version 4.0.0 and prior versions.

Weakness: CWE-470

Which versions are affected by CVE-2021-31522?

4 open source packages ship an affected version, including org.apache.kylin:kylin. It affects 1 product.

PackageAffectedFixed in
org.apache.kylin:kylin MavenAll versions3.1.3
org.apache.kylin:kylin MavenAll versions3.1.3
org.apache.kylin:kylin MavenFrom 4.0.04.0.1
org.apache.kylin:kylin MavenFrom 4.0.04.0.1

Products include Apache Kylin.

How do I fix CVE-2021-31522?

Upgrade org.apache.kylin:kylin to a fixed version for your release line: 3.1.3 or 4.0.1.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2021-31522 being exploited?

There is no known exploitation of CVE-2021-31522 in the wild and no public exploit code.

Sources

Also known as GHSA-q656-g2x3-8cgh.

Is CVE-2021-31522 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free