{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.kylin:kylin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-31522 in the wild and no public exploit code.","fix":"Upgrade org.apache.kylin:kylin to a fixed version for your release line: 3.1.3 or 4.0.1.","what":"CVE-2021-31522 is a critical code injection vulnerability in Apache Kylin, published on 6 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-31522 and fix it if it is affected.\n\nWhat it is: CVE-2021-31522 is a critical code injection vulnerability in Apache Kylin, published on 6 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-31522 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.kylin:kylin (Maven): affected all versions; fixed in 3.1.3\n- org.apache.kylin:kylin (Maven): affected all versions; fixed in 3.1.3\n- org.apache.kylin:kylin (Maven): affected from 4.0.0; fixed in 4.0.1\n- org.apache.kylin:kylin (Maven): affected from 4.0.0; fixed in 4.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-31522/ (Markdown: https://insights.sbomify.com/CVE-2021-31522/index.md)","id":"CVE-2021-31522","markdown":"https://insights.sbomify.com/CVE-2021-31522/index.md","name":"CVE-2021-31522","record":{"aliases":["GHSA-q656-g2x3-8cgh"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Kylin","requires_auth":"none","summary":"Attacker can execute arbitrary code via unsafe class loading in Apache Kylin, requiring immediate upgrade to patched versions.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"kylin","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-470","name":"Use of Externally-Controlled Input to Select Classes or Code"}],"description":"Kylin can receive user input and load any class through Class.forName(...). This issue affects Apache Kylin 2 version 2.6.6 and prior versions; Apache Kylin 3 version 3.1.2 and prior versions; Apache Kylin 4 version 4.0.0 and prior versions.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Kylin unsafe class loading","id":"CVE-2021-31522","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":4,"n_references":2,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2021-31523"},"packages":[{"ecosystem":"Maven","fixed":["3.1.3"],"introduced":["0"],"last_affected":[],"package":"org.apache.kylin:kylin","purl":null,"source":"GHSA-q656-g2x3-8cgh"},{"ecosystem":"Maven","fixed":["3.1.3"],"introduced":["0"],"last_affected":[],"package":"org.apache.kylin:kylin","purl":"pkg:maven/org.apache.kylin/kylin","source":"GHSA-q656-g2x3-8cgh"},{"ecosystem":"Maven","fixed":["4.0.1"],"introduced":["4.0.0"],"last_affected":[],"package":"org.apache.kylin:kylin","purl":null,"source":"GHSA-q656-g2x3-8cgh"},{"ecosystem":"Maven","fixed":["4.0.1"],"introduced":["4.0.0"],"last_affected":[],"package":"org.apache.kylin:kylin","purl":"pkg:maven/org.apache.kylin/kylin","source":"GHSA-q656-g2x3-8cgh"}],"prev":{"headline":"Cross-site scripting in Trend Micro InterScan Web Security Virtual Appliance","id":"CVE-2021-31521"},"products":["Apache Kylin"],"published":"2022-01-06","related":[{"cvss_score":8.8,"headline":"Apache Kylin OS Command Injection","id":"CVE-2020-1956","kev_date_added":"2022-03-25","published":"2020-05-22"},{"cvss_score":9.8,"headline":"Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API","id":"CVE-2026-62390","kev_date_added":null,"published":"2026-07-14"},{"cvss_score":9.8,"headline":"Apache Kylin: Command injection by Diagnosis Controller","id":"CVE-2022-44621","kev_date_added":null,"published":"2022-12-30"},{"cvss_score":9.8,"headline":"Apache Kylin vulnerable to remote code execution","id":"CVE-2022-24697","kev_date_added":null,"published":"2022-10-13"},{"cvss_score":9.8,"headline":"Command injection","id":"CVE-2021-45456","kev_date_added":null,"published":"2022-01-06"},{"cvss_score":9.8,"headline":"Command Injection in Kylin","id":"CVE-2020-13925","kev_date_added":null,"published":"2020-07-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Apache Software Foundation"]},"summary":"Attacker can execute arbitrary code via unsafe class loading in Apache Kylin, requiring immediate upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2021-31522/"}